Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm on Ubuntu 12.04 x64bit, installed it couple of days ago.

The issue i'm having is this: on startup it connects to my wireless without a problem, but after a while I am disconnected and prompted to enter the key for the wireless network (which is entered - saved) so i just click 'ok', but wireless doesn't connect again.

Reseting network manager doesn't help either. Only restart, after which, ubuntu connects to the said wireless without a problem.

Terminal outputs this error message: ** Message: No keyring secrets found for cimermanovic /802-11-wireless-security; asking user.

cimermanovic is the ssid name.

also, here are some error messages that network manager is giving:

(nm-applet:31926): GdkPixbuf-CRITICAL **: gdk_pixbuf_scale_simple: assertion `dest_width > 0' failed

(nm-applet:31693): GdkPixbuf-CRITICAL **: gdk_pixbuf_scale_simple: assertion `dest_width > 0' failed

(nm-applet:30184): GdkPixbuf-CRITICAL **: gdk_pixbuf_scale_simple: assertion `dest_width > 0' failed

What should i do to fix this?

Thanks!

share|improve this question

3 Answers 3

  1. I have experienced this issue with an Atheros card (not sure which driver), and swapped it out for an RALink that uses RT2790.
  2. MY laptop is an Asus EeePC 1000HE
  3. Fresh install
  4. This laptop worked with many previous Ubuntu versions from 9.04 to at least 11.04 (I was running stable on 10.10 for a long time) This issue only appeared in 12.04?
  5. I switched to xfce because unity killing my machine (fan was on all the time). Yes, I do have a Panel at the bottom?
  6. This happens even when I don't have any windows open at all. For me, it rarely happens when I am actively using the laptop. It will usually only happen if I leave it for any length of time. When I come back I could have dozens of prompts for wifi password.

Both of your potential work arounds will fix this issue. I am currently running a cron job to check for network status, and run those commands if it is not connected, but it is not a good solution.

share|improve this answer

This would happen to me if I used my cordless 2.5Ghz phone near my laptop.   Microwave ovens also bother it if they're close by, so don't discount outside interference as a possibility.

share|improve this answer

[Need to add this as a comment, but not enough rep.]

Some pertinent questions might help with debugging this:

  1. Do you have an old Broadcom wifi card? BCM43xx?
  2. What is the laptop model?
  3. Did you upgrade in-place from an older Ubuntu version or installed fresh?
  4. If you have used the same hardware on a prior Ubuntu release: did it work fine earlier ? Did this issue only appear in Pangolin?
  5. Are you using Gnome Panel or Unity? Do you have a Panel at the bottom?
  6. Does this happen when you open a lot of connections at once? Like opening multiple tabs with several image links in each? Or try out that scenario to see if triggers this.

Possible Workarounds:

  1. Try toggling the "Enable wireless", "Enable Networking" checks in nm-applet and the hardware wifi switch. (In various combinations of these three toggles perhaps)

  2. Reset networking

    killall nm-applet
    sudo service network-manager restart
    nm-applet &
    
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.