Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu, I've been a longtime Debian user but I'm a bit lost with some things.

My admin account has everything working nicely, I created a standard user account for my wife but I haven't been able to make the webcam work on her account.

I was thinking it had to be something related to the groups, when I ran groups on the admin account I got this: ale adm cdrom sudo dip plugdev lpadmin sambashare

Groups for my wife account: valentina nopasswdlogin

I was kind of expecting my account to have the usual groups (video, audio, etc), but got lost with this info. Any suggestions?

Help in advance.

share|improve this question

2 Answers 2

Nopasswdlogin breaks a lot of things.

Don't use it for GUI login.

Use the built-in auto-login functionality instead(nopasswdlogin is supposed to be reserved for command-line users and is intentionally broken for GUI users).

enter image description here

share|improve this answer
    
I changed the my wife's user like you suggested but with no luck. After that I added her to the video group like @Thomas suggested in the answer below and no luck either. Any other suggestions? Thank you for such a quick answer. –  user1294431 Jun 10 '12 at 22:25
    
Are you sure you removed her from the nopasswdlogin group and restarted and didn't just turn on autologin? –  hbdgaf Jun 10 '12 at 22:29
    
Yes. From what I understand regarding groups there's no reboot needed, just to log out and back in. I rebooted anyway and nothing. valentina@piemur:~$ groups valentina video –  user1294431 Jun 10 '12 at 23:37
    
I'll dig in to it in a VM for a bit tonight. I expect to update the answer or comment 'no dice' tomorrow. –  hbdgaf Jun 10 '12 at 23:39
    
Thank you for taking the time. I appreciate it. –  user1294431 Jun 10 '12 at 23:42

Your are right - this is a question of groups. You need to have the group video to use the webcam.

share|improve this answer
    
in a case where I tested this, being in appropriate groups didn't fix some issues (automounting for example). that's why i recommended not using nopasswdlogin instead of adding video...to stave off future questions. –  hbdgaf Jun 10 '12 at 9:20
    
My webcam has these rights: crw-rw----+ 1 root video 81, 0 Jun 9 13:16 /dev/video0. So from my understanding you have to have the video group to use is. Of course you are right - nopasswdlogin breaks several tings. –  Thomas Jun 10 '12 at 18:17
    
Thank you for your answer @Thomas, unfortunately neither adding the group or not using nopasswdlogin helped. If you have any more suggestions I appreciate it. Thank you again. –  user1294431 Jun 10 '12 at 22:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.