Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have ubuntu 12.04 installed on windows 7. When I use the Fn alongside the key to reduce brightness, or even using the system settings, I am not being able to reduce the screen brightness. What is the problem?

share|improve this question
@JorgeCastro it is sony vaio VPCEH38FN, but i dont know how it shud help – user69656 Jun 18 '12 at 13:10
possible duplicate of Brightness doesn't change on Sony laptop – belacqua Nov 3 '12 at 22:36


sudo gedit /etc/default/grub

Update these lines:


... with the following arguments:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Then run sudo update-grub and reboot.

share|improve this answer
hey..this is not working for me..Instead my Fn key has completely stoppd working, first it showed the brightness bar, but the brightness just didnt reduce..Now, it is not even showing the brightness level when I press the Fn key alongside key to reduce brigtness. – user69656 Jun 11 '12 at 5:41
It worked on my system with the 2 modifications on one line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor" – To Do Dec 13 '12 at 14:45

I have a SONY VPCEG Vaio and to manipulate brightness in Ubuntu. Based on a article that I lost, I use this:

share|improve this answer

Here's how i fixed mine :

LCD Brightness Control

Once you have installed the proprietary Nvidia drivers as suggested above, you may notice that your brightness control keys do not work properly. This is fixable by editing one's xorg.conf file. Open a terminal window and type the following:

sudo nano /etc/X11/xorg.conf

This will open your X server configuration (after prompting for your password). You should see a section titled "Device" that looks as follows:

Section "Device"
        Identifier      "Default Device"
        Driver  "nvidia"
        Option  "NoLogo"        "True"

Append a line so it appears like this:

Section "Device"
        Identifier      "Default Device"
        Driver  "nvidia"
        Option  "NoLogo"        "True"
        Option "RegistryDwords" "EnableBrightnessControl=1"

You will need to restart your graphical server (or reboot) for this change to take effect.

share|improve this answer
Thanks. This worked for me on my Sony Vaio VPCF127FX. – brianpeiris Oct 9 '13 at 8:09

There is an app for it...Brightness And Lock

enter image description here

enter image description here

share|improve this answer
but u dont have the option to reduce or increase the brightness in this app.. – user69656 Jun 19 '12 at 14:44
I've edited the answer with a can see the brightness slider... – deostroll Jun 19 '12 at 14:52
is this in 12.04, cause i am not being able to see one... – user69656 Jun 19 '12 at 14:53
post the screenshot of your system settings on some image service like that link here – deostroll Jun 19 '12 at 14:56
OK. Hold on deostroll. – user69656 Jun 19 '12 at 15:04

I had the same problem and I solved it as follows.

This page shows how to set up the 3D cube and I am enclosing it because I used the same tool: CompizConfig Settings Manager.

That page tells you what to install and how to do it. Once it's installed, open CompizConfig Settings Manager, go to Accessibility > Opacity. Click on the Brightness and Saturation/*Brightness* tab.

Enable "Increase and Decrease Brightness" and set the key combination for it. Be careful. CompizConfig Settings Manager is a very powerful tool and if you don't know what you are doing, you may damage your Ubuntu system.

I would have posted screenshots but it is prohibited to new users. It is fairly simply though.

share|improve this answer
Can you post the screenshots elsewhere and link someone eventually come and modify this post to include it in your answer – deostroll Jun 17 '12 at 17:12
hey christos, this is not working for me..i did exactly wt u said, but nothing is happening.. – user69656 Jun 18 '12 at 13:05
@christos If you post a comment with link(s) to screenshot(s), and you ping me in the comment (by including the string @EliahKagan), I'll put them in this answer for you. – Eliah Kagan Aug 6 '12 at 4:01

I have a SONY Vaio E15 ( E15113 ) and was able to solve the problem using the solution mentioned in an earlier post

share|improve this answer
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – Peachy Sep 13 '12 at 17:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.