Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

According to Alsamixer I do have a HDA Intel soundcard with Nvidia MCP77/78 HDMI chip (Realtek sound card on MSI notebook).

When I use Skype under Ubuntu 12.04 for video calls, the other side hears background noise such as in Windows when you have your microphone boosted. In fact they can hear everything, even the fans turning on.

There is nothing tweaked on Ubuntu's fresh installation. Also tried this site:

https://code.launchpad.net/~ubuntu-audio-dev/+archive/alsa-daily/+packages ,

but there are no *.deb files that I can test if any fix the problem.

The question is if there is a way to add/tweak something to enable on software level the noise cancellation like the Windows sound drivers have that option.

I use my build in mic.

share|improve this question

5 Answers 5

Apart from changing into a narrow scope mic, there is nothing much you can do, this factor depends on the design of the microphone and not Skype.

share|improve this answer
    
I've the same issue -- and it only affects skype. No google hangouts, no viber. Just skype. –  Adobe Feb 18 at 19:57

Try changing the values in the Skype options > sound devices. The configuration must be like this:

Sound In: HDA Intel

Sound Out: pulse

Ringing: pulse

The sound in device must be your device

share|improve this answer
    
I have this already done. Does not have the seeking effect. –  T.C. Jun 10 '12 at 11:33
    
Any other ideas ? Anyone ? –  T.C. Jun 15 '12 at 8:28

I had the same problem ;)

Went to options -> sound devices -> open pulse audio volume control -> input devices

And then reduced the bars in order to be closer to Base.

Hope it helps

share|improve this answer

Your mic is going to forward what it detects. I think your best bet it to use a mic closer to your mouth so your voice is reletively much louder than the background noise. I use a USB headset for earphones and mic, and it's so much better than the built-in speakers and mic.

share|improve this answer

I've the same problem. The only solution I found is Options -> Sound Devices -> Check "Allow skype to automatically adjust my mixer levels". But it gives me another issue -- when calling to landline the microsoft boost is too slow, and I'm hardly heard.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.