Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I exclude all the svn metadata while synchronizing with unison?

So that all subfiles/folders are also ignored!

Thank you for you help

share|improve this question
add comment

3 Answers

In your preferences file:

ignore Name .svn

On the command line: unison -ignore 'Name .svn'.

It's a little weird to synchronize svn checkouts though. Usually people keep separate checkouts on separate machine and synchronize via the repository.

share|improve this answer
add comment

You can exclude specific files or directories by putting "ignore" lines in your unison config file. This should be ~/.unison/default.prf (or whatever the config file is for your specific sync profile).

[edited to just be where to put the ignore lines, since Gilles' answer solved the specific question better]

share|improve this answer
    
That only ignores .svn at the root of the synchronization tree, not in subdirectories. –  Gilles Nov 25 '10 at 21:37
add comment

I haven't tested this myself, but according to the manual, the --ignore "*/.svn/*" option should help.

share|improve this answer
    
That just doesn't work (you need one of the keywords Name, Path or Regex in the pathspec). Where did you find it in the manual? –  Gilles Nov 25 '10 at 21:38
    
From the terminal, man unison: -ignore xxx add a pattern to the ignore list –  João Pinto Nov 25 '10 at 22:15
    
ão: Ah, ok. Unison's terminology is indeed confusing here: it calls the whole Name foo a pattern, not just the foo part. –  Gilles Nov 26 '10 at 21:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.