Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was looking for Update Manager on Ubuntu 10.10 Netbook Edition and couldn't find it, so in Terminal I did:

sudo apt-get update
sudo apt-get upgrade

I got a message saying some packages were "held back" and searching online gave me the suggestion to do:

sudo apt-get dist-upgrade

So I did that and it updated my kernel and now uname -a says I have 2.6.35-23-generic #40-Ubuntu SMP. My system is still working normally, but I'm now second-guessing if I did the right thing. Was this kernel update meant for the next version of Ubuntu? Should I try to back it out?

share|improve this question
1  
If it ain't broke, don't fix it nor worry about it. –  msw Nov 25 '10 at 13:22
    
Incidentally, where is Update Manager? Since upgrading to 10.10 (Netbook) I can't find it –  SpashHit Nov 25 '10 at 16:28
    
goto dash then in search type update manager. –  Alaukik Jan 23 '11 at 12:04
add comment

2 Answers 2

dist-upgrade has some advanced package dependency resolution that is used (possibly needed) when a package changes it's major version.

Updates, for example, will always keep your version of OpenOffice 1.x up to date, but as soon as the distribution switches to OpenOffice 2.x, a dist-upgrade will be needed to resolve some more complicated issues.

So: You didn't do anything wrong. If you want, you can always do sudo apt-get dist-upgrade. It happens automatically if needed (via Update Manager), but you may invoke it manually to your hearts content.

Safe for errors in the repository apt is pretty much bullet proof these days. :)

share|improve this answer
add comment

The only difference between apt-get upgrade and apt-get dist-upgrade is that dist-upgrade will install new packages or remove installed packages if that is necessary to fulfil package dependencies, while upgrade will hold back packages whose dependencies can't be fulfilled by just upgrading.

So if there are some hold back packages usually apt-get dist-upgrade is The Right Thing To Do.

But it's a good idea to first have a look on what it wants to do, especially if you are using unofficial packages sources like PPAs or apt-get dist-upgrade wants to remove packages.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.