Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to have more than one user logged on at the same time, on the same computer.
Each user should have a full GUI X session...

It's easy enough to log in to multiple concurrent non-X linux terminals... but I want the X factor...

Maybe I've missed something, but I only see a Main Menu option to Log out of the current user, and nothing for "Switch User"...

Is there a simple way to do this?

share|improve this question
Do you mean having multiple users use the same keyboard/mouse, or different keyboards/mice? The solutions to those problems are different. – evgeny Nov 25 '10 at 11:19
Just a single keyboard/mouse/monitor. – Peter.O Nov 25 '10 at 11:54
up vote 3 down vote accepted

If you are using Gnome:

Try running gdmflexiserver, it will launch a new GDM session. You can switch between them using Ctrl+Alt+F{8..12}.

Take note though that logging in with the same user twice is a bad idea.

Also, (in Lucid, at least) you can switch users by clicking the Power button in top-right corner and then selecting a user name. alt text

share|improve this answer
Evgeny.. for some reason I don't have that Switch option (but it is present in my VM installation of Ubuntu.. I checked just now)... and checking further... Aha! I see now!.. A couple of months ago, I got rid of the bottom panel entirely, and heavily trimmed the top panel... and (until today) I did not need the "Indicator Applet Session", so I removed it ... I had replaced the "Menu Bar" with "Main Menu" which showed only "Log off".. So, problem solved! (it's all part of the learning curve :( .. gdmflexiserve looks interesting.. and thanks about the warning of double log-on.. Thanks – Peter.O Nov 25 '10 at 11:34
No problems, mate. – evgeny Nov 25 '10 at 11:35
I've seen what happens when two X sessions run with the same user (or with sudo): the X authority for the older session gets overwritten. One could use "sudo xhost +local:" as a partial workaround but it still is an issue, gksu in particular doesn't like it. – Paul Stelian Feb 5 at 20:18

If you want multiple users to use Keyboards/Mouse then that is multiseatX.See this documentation

share|improve this answer
Okay, thanks... Today I only have a single keyboard to consider, but your info is good to know... Ubuntu! It's got the lot! :) – Peter.O Nov 25 '10 at 11:50
You are welcome. – karthick87 Nov 25 '10 at 11:54

With first X session running login as user you want to use and run in an xterm or at a console prompt: xinit -- :1 or: startx -- :1

share|improve this answer
This works in 12.04 LTS. Thanks – Geppettvs D'Constanzo Apr 3 '13 at 19:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.