Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am not able to install any packages from terminal or software center.

Something wicked happened resolving 'your_proxy: 800' (-5 - No address associated with hostname).

This error pops up. I need help.

share|improve this question
    
- check you sources.list for errors (or add it into this question) - also check /etc/hosts and make sure it contains a line for 127.0.0.1 with localhost and a line 127.0.1.1 for your hostname - allso check /etc/hostname and make sure that this contains your hostname - can you connect to the internet with this system? (ie. does ping www.google.com work? ) –  Rinzwind Jun 9 '12 at 19:09
1  
yes.it contains all that you have told. –  sachin Jun 9 '12 at 21:00
    
"...this problem is ... a short-lived problem with (or accessing) your DNS server. (The problem is not actually with the server at archive.scrapy.org itself, though it may have been due to a configuration problem for that server's DNS record.)" Quotation from this answer. –  Gediminas Jeremiah Gudelis Jul 26 '13 at 17:52

3 Answers 3

You set a proxy for apt in your system. Probably you'll find it in a file in /etc/apt. You can use grep to find the entry:

sudo grep -r your_host /etc/apt

If it doesn't find anything check the environment variable http_proxy.

However according to the error message the proxy is set to the host your_proxy and port 800. But your system fails to resolve this hostname. So check the hostname for typos or other errors and try to use the correct setting. If you use the correct version, your proxy will work.

share|improve this answer

I have encountered this same problem, and solved it simply by opening up my software properties

 software-properties-gtk

and changing the drop down dialog Download from: to Main Server.

I had trouble using the us server.

You can also switch over to your "Other Software" tab and uncheck any PPA's you have added. Then run

sudo apt-get update

and hopefully your problem will be resolved.

share|improve this answer

You set a proxy in your /etc/apt.conf. Look for the line

Acquire::http::proxy "http://your_proxy:800";

and either correct it with the correct proxy information or delete it.

A full line might look like:

Acquire::http::proxy "http://username:password@yourproxy:80";
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.