Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed the latest Nvidia drivers for my FX5500 card. I understand that the X server version does not officially support this driver or card but was wondering what I can do to get Compiz running. I have researched for hours on this issue but cannot come up with an answer for myself. I might be doing all this for nothing but I wanted to at least try.

Here is the output of my test:

mike@mike-linux-box:~$ /usr/lib/nux/unity_support_test -p   
OpenGL vendor string:   NVIDIA Corporation
OpenGL renderer string: GeForce FX 5500/AGP/SSE2
OpenGL version string:  2.1.2 NVIDIA 173.14.35
Not software rendered:    yes
Not blacklisted:          no
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes 
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes
Unity 3D supported:       no

So I was wondering what is the "Not Blacklisted" test? Is this the Nouveau blacklisting? Nvidia driver did that automatically. Does this need to be removed? Any help would be appreciated. I just want to run Compiz effects.

Thanks.

share|improve this question

2 Answers 2

Blacklisting is simply making a list of those cards that do not work (well) with Compiz/Unity 3D. So, your card is not supported because somebody decided that the way it works is unsatisfactory. You can try to override this by pressing Alt+F2 and typing gksu gedit /etc/environment

Once it opens, add a new line and add:

UNITY_FORCE_START=1

If it does not work (which is probable), then you can log in to Unity 2D by clicking the gear icon before you type your password and selecting Unity 2D, and then deleting this line from /etc/environment.

share|improve this answer
    
Thanks but don't want to break my system again! :) –  user69545 Jun 9 '12 at 19:37
    
Remember, you can undo this by logging into Ubuntu 2D(See bottom of answer) and deleting the line from /etc/environment. –  hexafraction Jun 10 '12 at 16:48

If you're running 12.04 there is no legacy driver available in the repo:

https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-173/+bug/948053

Nvidia maintain the 173 and 96 branch for legacy cards, however at the time 12.04 shipped the 173 and 96 branches had not been updated to run with the version of X11 that 12.04 was shipping with.

Since then 173 has been released by Nvidia but it has not been packaged for Ubuntu yet, provided that your card does not require the 96 branch you should be able to fix this issue by installing it manually from here:

ftp://download.nvidia.com/XFree86/Linux-x86/173.14.35/

You will need to rebuild this every time a new kernel is released.

In the bug report a method is suggested, which I have tried and which does work, but is not recommended.

Posted by Nicolas VILA (nicolas-vila):

"So I stick with 11.10 version of X.Org. I had to make the following changes to backport X.Org:

In /etc/apt/sources.list:

deb http://fr.archive.ubuntu.com/ubuntu/ oneiric main
deb-src http://fr.archive.ubuntu.com/ubuntu/ oneiric main

In /etc/apt/preferences:

Package: xserver-xorg*
Pin: release a=oneiric
Pin-Priority: 1050"

Personally my long term solution was just to buy a newer card from Amazon as legacy cards are likely to get hit with this kind of problem every new Ubuntu release.

share|improve this answer
    
Any card suggestions? Also, is AGP supported at all? or just PCI-E cards? –  user69545 Jun 9 '12 at 19:37
    
I got this card because its cheap and has a new chipset so it should become legacy slower amazon.co.uk/gp/product/B0083IH9WI/… –  MickStep Jun 9 '12 at 19:45
    
I can't seem to see any nvidia AGP cards with newer chipsets unfortunately. However both methods I suggested should work if you want to give them a go. The method where you use the xserver from 11.10 is fine as long as you are ok with undoing what you did via the command line should you need to. –  MickStep Jun 9 '12 at 19:51
    
Also it's worth mentioning that 173 will get packaged for 12.04 sooner or later when the dev gets round to it. –  MickStep Jun 9 '12 at 19:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.