Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is it possible to edit the Blacklist.conf file when running Linux off a Live CD? If so, how do you edit it?

I tried typing this into the terminal but nothing happened:

gksudo gedit /etc/modprobe.d/blacklist.conf
share|improve this question
    
The problem here is that because (according to this question's tagging) you're running Lubuntu, the preinstalled text editor is leafpad, but you're trying to edit the file with gedit (preinstalled in regular Ubuntu systems and live CD's). That's the cause of the problem. Elfy's answer explains how to fix your problem (by running leafpad instead). –  Eliah Kagan Jun 10 '12 at 6:33
add comment

2 Answers

First you would need to have the files for the system you want to edit mounted.

Look in the left panel for the file system in pcmanfm (the file manager) and click on it - it will look 'similar' to this

enter image description here

You can see that I have mounted my 12.10 partition

Check what the path is called for you - could be /media/long UUID reference and then run

gksudo leafpad /media/longUUIDreference/etc/modprobe.d/blacklist.conf

from a terminal.

share|improve this answer
    
what if it isn't mounted? How would I mount it? –  mike Jun 9 '12 at 18:31
    
Click on that drive in pcmanfm - it should be in the left panel, my 12.10 wasn't mounted until I clicked on it. –  Elfy Jun 9 '12 at 18:43
add comment

If you'd like to prevent a certain module from loading at boot time ("blacklisting"), you could append the boot option modprobe.blacklist=<module-name>. E.g., to prevent nouveau from loading, you'd use modprobe.blacklist=nouveau.

To do so on an installation, see How do I add a kernel boot parameter?. For a Live CD/USB, see How to input commands on the Live CD mode selection screen (I believe that you need to press a different key first in newer versions, e.g. Space).

share|improve this answer
    
well what I am trying to do is get my wireless network to work and someone told me to add the following to the blacklist.conf file: "blacklist padlock_aes" and "blacklist geode_aes" So would I be able to do that? –  mike Jun 9 '12 at 18:27
    
In other words, what should I type exactly? –  mike Jun 9 '12 at 18:34
    
Try modprobe.blacklist=padlock_aes,geode_aes (actually, it should not matter whether you use padlock_aes or padlock-aes as name). –  Lekensteyn Jun 10 '12 at 8:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.