Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday i went to work and closed my laptop. When i got home I couldn't get the lock screen to come back up. ctrl+alt+f2 to get to a terminal and Tried to kill compiz, compiz was not running so I tried to restart it got an error opening the display so i tried to restart lightdm again couldn't open display. so I restarted and now I am stuck on the loading screen. I tried booting in recovery mode and all options hang except root, but i'm stuck with read only. booting from a live cd I can mount the drive but again stuck with read only. I'm completely stuck here. checking my default-display-manager returns "/usr/sbin/elsa" as the only line and can't edit it. I've got an 11.10 live cd and my /home is encrypted so i can't try to back anything up at the moment either. How can i resolve this or at the least back up some of my data? Please help!

share|improve this question
    
So, I went through and tried out changing some things. Change default-display-manager to standard settings for lightdm that I found on this site. Still no boot. I copied xorg.conf.failsafe to xorg.conf, still no boot. I would love to be able to save this install someway. fsck shows file system intact. yet still can't open the display manager. When I try to load in failsafe graphic mode somewhere along the process it freezes. ctrl+c and it starts a string of thing ending up at the e17 login (instead of the gnome it normally does) and I can't login with my password. Any help would be great. –  schonjones Jun 10 '12 at 15:31

1 Answer 1

up vote 1 down vote accepted

I couldn't get elsa working, but by running sudo dpkg-reconfigure lightdm I was able to resolve the boot issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.