Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I trying to install this following these instructions:

sudo apt-get remove ffmpeg x264 libx264-dev
sudo apt-get update
sudo apt-get install build-essential subversion git-core checkinstall yasm texi2html libfaac-dev libfaad-dev libmp3lame-dev libopencore-amrnb-dev libopencore-amrwb-dev libsdl1.2-dev libx11-dev libxfixes-dev libxvidcore4-dev zlib1g-dev
cd
mkdir ffmpeg-x264-avfilter
cd ffmpeg-x264-avfilter
git clone git://git.videolan.org/x264.git
cd x264
./configure
make
sudo checkinstall --pkgname=x264 --pkgversion "1:0.svn`date +%Y%m%d`+`git rev-list HEAD -n 1 | head -c 7`" --backup=no --default
cd ..
svn checkout svn://svn.ffmpeg.org/soc/libavfilter
cd libavfilter
./checkout.sh
cd ffmpeg
./configure --enable-gpl --enable-version3 --enable-nonfree --enable-postproc --enable-pthreads --enable-libfaac --enable-libfaad --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libx264 --enable-libxvid --enable-x11grab --enable-avfilter --enable-avfilter-lavf
make
sudo checkinstall --pkgname=ffmpeg-avfilter --pkgversion "4:0.5+svn`date +%Y%m%d`" --backup=no --default

I got these errors:

Unknown option "--enable-libfaad".
Unknown option "--enable-avfilter-lavf".
ERROR: libfaac not found

What am I doing wrong?

share|improve this question
    
Any errors when running apt-get install libfaac-dev? Also, remove the unknown options. Also, please learn to indent your code properly with 4 spaces, then you don't have to do the backticks thing. –  slhck Jun 9 '12 at 12:55
1  

7 Answers 7

Well, install libfaac first. It seems there was an error doing so. Make sure apt-get install libfaac-dev works.

The proper instructions for installing FFmpeg and x264 are here.

sudo apt-get update
sudo apt-get -y install build-essential checkinstall git libfaac-dev libgpac-dev \
  libjack-jackd2-dev libmp3lame-dev libopencore-amrnb-dev libopencore-amrwb-dev \
  libsdl1.2-dev libtheora-dev libva-dev libvdpau-dev libvorbis-dev libx11-dev \
  libxfixes-dev texi2html yasm zlib1g-dev

Then, for x264:

cd
git clone git://git.videolan.org/x264
cd x264
./configure --enable-static
make
sudo checkinstall --pkgname=x264 --pkgversion="3:$(./version.sh | \
  awk -F'[" ]' '/POINT/{print $4"+git"$5}')" --backup=no --deldoc=yes \
  --fstrans=no --default

And for FFmpeg:

cd
git clone --depth 1 git://source.ffmpeg.org/ffmpeg
cd ffmpeg
./configure --enable-gpl --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb \
  --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis \
  --enable-libx264 --enable-nonfree --enable-version3 --enable-x11grab
make
sudo checkinstall --pkgname=ffmpeg --pkgversion="5:$(date +%Y%m%d%H%M)-git" --backup=no \
  --deldoc=yes --fstrans=no --default
hash x264 ffmpeg ffplay ffprobe

That's it — filters should be automatically included.

share|improve this answer

I found that in Ubuntu 12.04 libfaac-dev wasn't installable, so following these instructions (http://superuser.com/questions/467774/how-to-install-libfaac-dev) I enabled the multiverse repository:

sudo nano /etc/apt/sources.list

Removing the hashes on the following lines to enable the repo:

deb http://eu-west-1.ec2.archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://eu-west-1.ec2.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://eu-west-1.ec2.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://eu-west-1.ec2.archive.ubuntu.com/ubuntu/ precise-updates multiverse

Run:

sudo apt-get update
sudo apt-get install libfaac-dev

That should solve this error.

share|improve this answer

If your installing on ec2 ubuntu instance...

you must upgrade to this yasm, which isn't in the repos

.....

 install yasm

 wget http://www.tortall.net/projects/yasm/releases/yasm-1.2.0.tar.gz

 tar xvzf yasm-1.2.0.tar.gz

 cd yasm-1.2.0

 ./configure

 make && make install

 cd ..
share|improve this answer
    
Could you please explain why you are recommending this? The OP's error message has nothing to do with either yasm or ec2. –  Kevin Bowen Apr 8 '13 at 8:51
    
b/c as I was following this thread's instructions and I got to this --> Then, for x264: cd git clone git://git.videolan.org/x264 cd x264 ./configure --enable-static ..... I couldn't proceed unless I did what I just posted. –  sirvon Apr 8 '13 at 10:24

Please see this link.

Hope this will be helpful

share|improve this answer

Well if you have this error when you try to install ffmpeg then you must download lame from sourceforge

Open Terminal and write following

wget http://downloads.sourceforge.net/project/lame/lame/3.98.4/lame-3.98.4.tar.gz?r=http%3A%2F%2Fffmpeg.zeranoe.com%2Fforum%2Fviewtopic.php%3Ff%3D5%26t%3D94&ts=1339140293&use_mirror=ignum

After downloading try following one by one..

tar -zxvf lame-3.98.4.tar.gz

cd lame-3.98.4

./configure

make

make install

And you done.

share|improve this answer

Then, for x264:

cd

git clone git://git.videolan.org/x264

cd x264

./configure --enable-static

make

sudo checkinstall --pkgname=x264 --pkgversion="3:$(./version.sh | \ awk -F'[" ]' '/POINT/{print $4"+git"$5}')" --backup=no --deldoc=yes \ --fstrans=no --default

This is not enough for a static build x264 must not link to other dynamic libraries, use the following to avoid problems when it comes to compiling ffmpeg:

x264:

cd

clone git://git.videolan.org/x264

cd x264

./configure --enable-static 
--disable-opencl \ 
--disable-avs \ 
--disable-cli \ 
--disable-ffms \ 
--disable-gpac \ 
--disable-lavf \ 
--disable-swscale 

make

sudo checkinstall --pkgname=x264 --pkgversion="3:$(./version.sh | \ awk -F'[" ]' '/POINT/{print $4"+git"$5}')" --backup=no --deldoc=yes \ --fstrans=no --default
share|improve this answer

I fixed the libx264 error by installing libavcodec-extra-53 package:

sudo apt-get install libavcodec-extra-53
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.