Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm a Windows user and I have no experience with Linux and Ubuntu.

I installed Ubuntu 12.04 on my netbook (Asus 1215B) and everything works fine. Yesterday I ran the "update application" and updated over 120 "things" (I have no idea what exactly). After that I was asked to reboot, and I did.

Ubuntu starts again and at the load screen with these 5 dots that normally begin to change color, it freezes. After 20 minutes I took out the battery to try another reboot (yes, not the the best idea), and now nothing happens.

I boot from the HDD and I get an Error

BOOTMGR is missing.

I have important data on the hard drive. Is there an option to get this fixed? Or if not, to at least get the data from the hard drive?

Ubuntu 12.04 64-bit

Edit: it is ONLY Ubuntu on this Netbook, which uses the whole 500gb HDD as 1 Partition. Filesystem is NTFS. Whole Hardware seems okay. The USB drive which i used to instl the Os was formated in fat32

share|improve this question
    
How did you install Ubuntu? –  Mitch Jun 9 '12 at 10:03
    
via an image from usb-stick(with unetbootin). Ubuntu has 1 Partition with 500gb space. –  Felix Jun 9 '12 at 10:05
    
Can you see your drives when starting a live session from this USB-drive choosing "Try out Ubuntu", opening the file browser and click on the drive icons that may show up on top left to mount the partitions? –  Takkat Jun 9 '12 at 10:09
    
How was the USB drive formatted? –  Mitch Jun 9 '12 at 10:39

3 Answers 3

I finally got it.

At first I tried it with espectalll123's answer but I couldn't check my partition because it was mounted. So I just left it like that because I didn't want to destroy something in the process.

I finally got it with UbuntuSecureRemix. I had to run Boot-Repair, which is if you download it from the Ubuntu help thread (sorry I can't add more links) x86 and doesn't work for my x64 system. So I downloaded UbuntuSecureRemix which also has boot repair in it and is available for both 32-bit and 64-bit. So I booted this from an USB drive and just ran Boot Repair from the dash and two minutes later I rebooted from HDD and everything works fine.

share|improve this answer

The BOOTMGR error means that your hard disk drive is damaged. To check if the computer needs to be fixed, follow this instructions:

  1. Boot from a Linux Live CD, for example, from the Ubuntu installation CD.
  2. Open a terminal (in Ubuntu, open it searching in the dash)
  3. Type sudo fdisk -l and find your partition.
  4. Now type sudo fsck followed by the partition that you want to check.

If your PC is not damaged, do this:

  1. Record a CD or a floppy with Super Grub2 Disk.
  2. Boot Ubuntu from there.
  3. Open a terminal.
  4. Type grub-install /dev/sda

If your PC is damaged and you want to save the hard disk data, boot from the Ubuntu Live CD (or any other Debian-based) and follow the instructions shown here: http://www.debianadmin.com/recover-data-from-a-dead-hard-drive-using-ddrescue.html

share|improve this answer
    
fdisk can not repair a damaged NTFS partition –  Takkat Jun 9 '12 at 11:05
    
Yep, but he's user of Windows AND Ubuntu. Also, I thought that if his HDD is damaged, it would be seriously damaged... so I haven't posted anything about fixing the hard disk. –  espectalll123 Jun 9 '12 at 11:06

First try to press esc directly after the bios splash ends (the Asus logo) this could bring up a menu including ubuntu and some tools you can try to use an older version or the recovery mode

if this doesn't work https://help.ubuntu.com/community/Boot-Repair should help

Ubuntu can not be installed on a ntfs file system the Ubuntu-installer should have formatted to ext4

----------Deutsch/German---------
Direkt nach dem der Bios Bildschirm erlischt also ein Asus Logo drücke die esc Taste. Es sollte ein Menü erscheinen in dem sie ubuntu und unterschiedliche tools wählen könnten unter anderem ältere Versionen und ein Recovery Mode /Wiederherstellungsmodus. Diese beide Optionen könnten ihnen weiterhelfen. Wenn ihnen das nicht weiterhilft probieren sie https://help.ubuntu.com/community/Boot-Repair oder die Root-Directory methode die auf dieser Seite beschrieben wird: http://wiki.ubuntuusers.de/GRUB_2/Reparatur

Ubuntu kann nicht mit einem NTFS system installiert werden. Wahrschlich wurde die Festplatte neu formatiert und ist nun ext4

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.