Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I insert my MTS Mblaze modem in my system and I try to run it, the Mblaze application says that the device is wrong and asks me to insert the proper device. What should I do?

share|improve this question
    
how did you install mts mblaze software in ubuntu? it is for winodws. it won't work here. See here to setup askubuntu.com/questions/117945/… –  Web-E Jun 9 '12 at 8:42
    
@Web-E till last year i was using this hardware on my Ubuntu 10.10. It does have a .deb installer and works fine. It even supports on UNIX oracle solaris. However i stopped using this company for poor services excessively high rates and oppressive fair usage policy. The hardware is by ZTE and well supported on all platforms –  Z9iT Jun 9 '12 at 9:52
    
@Aarti Elly I would like to exclaim one thin, as you said "device is wrong and asks to insert the proper". This problem generally arise when you use some other device to install the software and now using another (modem) hardware with it. –  Z9iT Jun 9 '12 at 9:55
add comment

2 Answers 2

up vote 1 down vote accepted

For the first time when you insert your device; a new drive (like USB Pen-Drive) is automatically mounted.

Just browse across this drive, and search for a file with .deb extension with most probable name of the file being installer.version.something.deb

This deb file is the software and driver for your MTS Mblaze USB modem; which will help your system recognize the device.

As an extra piece of information, you USB modem hardware is supplied by a Chinese company ZTE if you are being bothered for the drivers then search ZTE's website. Alternativly just ring the MTS help-center

share|improve this answer
add comment

I was having the same prob. How ever found the solution to 90% of the prob. Firstly you might have to add a conf file in etc folder in the system folder. The file being called wvdial.conf you can do this by using sudo command. In other words install wvdial.

  1. Install wvdial using:

    sudo apt-get install wvdial
    
  2. Install usb-modeswitch and usb-modeswitch-data from Ubuntu Software Center

  3. Edit /etc/wvdial.conf using:

    sudo gedit /etc/wvdial.conf
    
  4. Add the following lines to the file:

    [Dialer mts]
    
    Stupid Mode = 1
    
    Inherits = Modem0
    
    Password = mts
    
    Username = internet@internet.mtsindia.in
    
    Phone = #777
    
    [Modem0]
    
    Init1 = ATZ
    
    SetVolume = 0
    
    Modem = /dev/ttyUSB0
    
    Baud = 115200
    
    FlowControl = Hardware (CRTSCTS)
    
    Dial Command = ATDT
    

Here is the deal. At times the modem may be recognized but will not initialize. Now here is what you have to do. After installing and inserting your modem it will pop up in the network manager in the right top corner of your desktop. Now click on the enable networking option and wait for atleast 10 to 15 secs before clicking on the enable mobile connection option. Then it will connect, the thing is the modem needs that much of time in order to work. I know it sounds silly but yup its true. And if the modem stops working in the middle after lets say a 3 hour session which is what is happening to me all you have to do is click on the enable networking option again from the start and the same process over again it should work. so far so good. Any more updates share it.

Well hope this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.