Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First off, I've read through all of the posts regarding BCM4312 on the forums but haven't been able to get any help.

Basically I have a Dell Inspiron 1564 which I've installed 12.04 on and for the most part everything works fine but now that I'm trying to use more in depth utilities such as aireplay and airodump I'm coming across what I believe to be a driver problem that's not allowing compatibility for these programs.

Does anyone out there have any suggestions how to resolve this?

This is the error I receive:

root@Haxornator:~/aircrack/aircrack-ng-1.1# airodump-ng eth2
ioctl(SIOCSIWMODE) failed: Invalid argument

ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211,
ARPHRD_IEEE80211_FULL or ARPHRD_IEEE80211_PRISM instead.  Make
sure RFMON is enabled: run 'airmon-ng start eth2 <#>'
Sysfs injection support was not found either.
share|improve this question
    
I have a 4312(LP-PHY) and I've not been able to use any of those tools either. It's a limitation in the driver, both STA proprietary and the opensource b43. Some cards work, some don't I'm afraid. –  duffydack Jun 9 '12 at 8:16
    
If no one knows the answer to your question, I think you should try the aircrack forums, there are usually lot of explanations there for different devices. –  enedene Jun 9 '12 at 9:39

1 Answer 1

You need to use the b43 drivers for your wireless card.

First, install b43-fwcutter:

sudo apt-get install b43-fwcutter

Then, download the file:

wget http://www.lwfinger.com/b43-firmware/broadcom-wl-5.100.138.tar.bz2

Extract it:

tar -pjxf broadcom-wl-5.100.138.tar.bz2

Install the driver:

sudo b43-fwcutter -w /lib/firmware broadcom-wl-5.100.138/linux/wl_apsta.o

Now, load the driver:

sudo modprobe b43; sudo modprobe -r wl

That worked for my BCM4312, and after that aircrack-ng worked very well.

share|improve this answer
    
Thank you for the reply, I followed your directions to the letter and after the last step my wireless card has now disappeared and is no longer working at all, please help –  Haxornator Jun 10 '12 at 1:21
    
scratch that, I rebooted went into system/additional drivers and disabled the " Broadcom STA wireless driver" then I went back to terminal and typed "sudo modprobe b43; sudo modprobe -r wl" which seems to have re-enabled the wireless card as I can see my wireless router and connect to it. –  Haxornator Jun 10 '12 at 2:05
    
I then tried "airodump-ng wlan0" (note that the new drivers changed my wireless card's name from eth2 to wlan0" and received the error device failed and it told me to enable RFMON and type "airmon-ng start wlan0 <#>" so I did and again tried airodump-ng wlan0 and it didn't work with the same error as previous –  Haxornator Jun 10 '12 at 2:20
    
THEN I typed "airmon-ng" and I can now see an additiona listing of mon0, so I typed airodump-ng mon0" and finally I'm getting it to work. Thank you internet! –  Haxornator Jun 10 '12 at 2:21
    
Sorry for the multiple comments, low rank means its difficult to ask questions and give advise. –  Haxornator Jun 10 '12 at 2:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.