Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday evening I changed my password, using: Systems Settings >> User Accounts

But, this morning my new password is not accepted. In trying other solutions, I tried my old password which still allowed me to login.

Please can anyone give me reason why this happen, and how I can stop this happening?

share|improve this question
4  
Have you tried changing it a second time? Maybe you didn't successfully change it the first time. –  Huckle Jun 9 '12 at 4:15
    
@Huckle tried now in CLI way . but failed . –  AgentCool Jun 9 '12 at 6:24

2 Answers 2

up vote 1 down vote accepted

Here is what you will need to do.. Lines starting with '$' are prompts, you don't type the '$'. Lines without the '$' are output, you don't type them either. Things inside <> should be replaced with your new or old password as indicated.

$passwd
Enter the new password (minimum of 5, maximum of 8 characters).
Please use a combination of upper and lower case letters and numbers.
Old password: <old password goes here>
New password: <new password goes here>
Re-enter new password: <new password goes here>
Password changed.
share|improve this answer
    
man i have tried CLI also but its not accepted , but you did man .now i have tested by locking screen and new password accepted that . after a restart i will make the final report –  AgentCool Jun 11 '12 at 14:43
    
I didn't fully understand your last comment. Did you, or did you not, get the same output as you see in my answer? If not, what output did you get (put it on pastebin). If yes, is there anywhere your new password does not work? –  Huckle Jun 11 '12 at 19:59
    
the thing is , you did it man successfully . I have tried both CLI way and GUI way but they havent update new password . but its working after trying your's . thanks man :) –  AgentCool Jun 12 '12 at 3:50
    
I'm glad it worked for you. On an unrelated note, no one says 'man' anymore. If they did, it would the phrase would go "man, you did it successfully" or even better "It was successful! You did it, man!" The 'man' is like an interjection and it belongs in its own clause. The sentence should read the same with and without the 'man' –  Huckle Jun 12 '12 at 4:31
    
i am not good with English because its not my mother tongue (i know reasons are not the answer and not recommended of course )and i am using it in my daily life (as a primary) from 4 years .So i think need more time . I am sorry for my mistakes but thanks for suggesting me ,the right way of using . –  AgentCool Jun 12 '12 at 9:26

Please can anyone give me reason why this happen, and how I can stop this happening?

This should NOT happen on a normal system. Try changing your password again, and then check it out immediately by trying a command which requires sudo, e.g. sudo apt-get update -- the new password is the one that should work.

share|improve this answer
    
tried but failed still old password ,even after changing 2nd time . –  AgentCool Jun 9 '12 at 6:25
    
Try in the terminal with passwd, and paste the output of ls -l /etc/passwd –  izx Jun 9 '12 at 7:07
    
its saying like Bad command ,here is the output raja@badfox:~$ cat ls -l /etc/passwd cat: invalid option -- 'l' Try `cat --help' for more information. –  AgentCool Jun 9 '12 at 12:32
    
somebody could help me on this. please –  AgentCool Jun 10 '12 at 10:30
    
@Raja, why did you use cat? Just type ls -l /etc/passwd at the prompt -- no cat. Please also pastebin the contents of /var/log/auth.log –  izx Jun 10 '12 at 10:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.