Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is there a simple way to add exFAT support to Ubuntu without kernel patching?

share|improve this question
Three years later, the answers below do not work. The PPA 404'd so I'm assuming is no longer maintained. Solution: I used a different USB stick. Will reformat this one in Windows. –  Chris K May 28 '13 at 18:19
Worked for me on 2013-06-28 for Ubuntu 12.04. –  mivk Jun 28 '13 at 10:23

4 Answers 4

A more detailed, step-to-step description on how to use the PPA pointed to by StalkerNOVA can be found on stackoverflow, copied here for the sake of completeness:

Do only once:

  1. Add the repository: sudo add-apt-repository ppa:relan/exfat
  2. Update the package list: sudo apt-get update
  3. Install the exfat package: sudo apt-get install fuse-exfat
  4. Create the mount folder: sudo mkdir /media/exfat

Everytime you want to access sdxc the card/exfat filesystem:

  1. Mount the filesystem (replace sdc1 with your exfat partition): sudo mount -t exfat /dev/sdc1 /media/exfat On some devices, cameras, for locked sdxc cards etc you might want to mount the filesystem read only, just add -o ro to the mount command line: sudo mount -t exfat -o ro /dev/sdc1 /media/exfat
  2. Read and write to /media/exfat to your heart's desire.
  3. When you are done, unmount the filesystem: sudo umount /media/exfat

The sdc1 in the step-by-step above refers to the linux device where your card/exfat filesystem resides on. If this changes (usb card readers, cameras) or you simply don't know which one it could be either use the menu system System -> Administration -> Disk Util and usually you will find your camera or card reader in the list on the left hand side. Or - as a quick shortcut - use cat /proc/partitions on a terminal command line. The latter is only useful if you know all the other unchanging device names on your system and thus can quickly identify the one added one.

Update for Ubuntu 13.10

According to Freddie's answer step 1. to add additional ppas is no longer required. Also, it seems fuse-exfat is no longer installable. The package to install is now named exfat-fuse and is available by default (universe repository). The package exfat-utils will also add the usual filesystem management tools including this package. Also thanks to this answer

share|improve this answer
With Ubuntu 12.04, you only need points 1 to 3 (add ppa, update, install). Automount will work as usual. –  mivk Jun 28 '13 at 10:33
up vote 5 down vote accepted

Google showed the answer... https://launchpad.net/~relan/+archive/exfat

share|improve this answer
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eliah Kagan Jan 9 '13 at 1:17
The better answer is askubuntu.com/a/85459/36661 –  MountainX Nov 3 '13 at 16:29

I followed http://namhuy.net/872/how-to-enable-exfat-on-ubuntu.html and it works for me

To install exfat on Ubuntu 13.10 Saucy Salamander, you don’t need to add any extra PPA to your sources list. You only need exfat-utils package

$ sudo apt-get update && sudo apt-get install exfat-utils

Ubuntu and Linux Mint will not automatic mount exfat devince. To mount exfat device, plug in your device and run:

$ su -
# cat /proc/partitions
# cd /media
# mkdir usbdrive
# mount -t exfat /dev/sdd1 usbexfat
share|improve this answer
for 13.10 see askubuntu.com/a/85459/20972 –  rogerdpack Jan 6 at 14:48

For Ubuntu 14.04 there is a package called exfat-fuse. The following worked for me:

sudo apt-get install exfat-fuse
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.