Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am following along a book in which Insight debugger is required. I didn't find it on my Maverick. I googled and I found that it's not supported in debian anymore but I really need to install it. I tried to compile the source and it installed but keep telling me that tk is missing whenever i start it. I installed tk with sudo aptitude install tk then tried to run again it's the same. I compiled it one more time and nothing really changes. So please how can I install that ?

Update: This is the message i get

Tk_Init failed: Can't find a usable tk.tcl in the following directories: 
    /usr/local/share/tk8.4 /usr/local/lib/tk8.4 /usr/lib/tk8.4 /usr/local/library /usr/library /usr/tk8.4.1/library /tk8.4.1/library

/usr/local/share/tk8.4/tk.tcl: no event type or button # or keysym
no event type or button # or keysym
    while executing
"bind Listbox <MouseWheel> {
    %W yview scroll [expr {- (%D / 120) * 4}] units
    (file "/usr/local/share/tk8.4/listbox.tcl" line 182)
    invoked from within
"source /usr/local/share/tk8.4/listbox.tcl"
    (in namespace eval "::" script line 1)
    invoked from within
"namespace eval :: [list source [file join $::tk_library $file.tcl]]"
    (procedure "SourceLibFile" line 2)
    invoked from within
"SourceLibFile listbox"
    (in namespace eval "::tk" script line 4)
    invoked from within
"namespace eval ::tk {
 SourceLibFile button
 SourceLibFile entry
 SourceLibFile listbox
 SourceLibFile menu
 SourceLibFile panedwindow
 SourceLibFile ..."
    invoked from within
"if {$::tk_library ne ""} {
    if {[string equal $tcl_platform(platform) "macintosh"]} {
 proc ::tk::SourceLibFile {file} {
     if {[catch {
    (file "/usr/local/share/tk8.4/tk.tcl" line 393)
    invoked from within
"source /usr/local/share/tk8.4/tk.tcl"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list source $file]"

This probably means that tk wasn't installed properly.
share|improve this question

Read that topic carefully and then add this to your repository.On my ubuntu 2.8 ultimate edition based on ubuntu 10.10 it worked!!!

share|improve this answer

Download it from here:*

* only for natty,maverick,lucid

share|improve this answer

The Ubuntu tk package installs the required .tcl files into /usr/usr/share/tcltk/tk8.4, check if there is some configuration file where you can change the tcltk search path .

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.