Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having trouble getting my nfs to mount on boot. I am running Lubuntu 12.04 and mounting from a NAS (Synology-if it matters). I should add that am very new to using Lubuntu or any Linux distribution.

To mount on boot I tried to add the following to /etc/fstab: /home/john/nfs-Family nfs rw,async,hard 0 0

No luck when the computer mounts, the nfs file doesn't mount.

I should add that when I use the mount command the nfs mounts just fine. This is the command I use:

sudo mount /home/john/nfs-Family

Any advice would be appreciated.

share|improve this question
Add auto the list of options (rw,asy...), that should do it – Tom Regner Sep 19 '12 at 6:22
have you tried checking to see if you client nfs daemon is running chkconfig netfs --list? – linux admin Apr 13 at 16:02

This question is a bit old but I thought I might share what solved this problem for me. I had this same issue after following the 12.04 server guide.

Everything has worked well since I changed my /etc/fstab entry options to include nfsvers=3 per comment #6 in this bug report. My current fstab entry (working on three clients) is as below. /home nfs nfsvers=3,hard,intr,auto 0 0
share|improve this answer
I've tried so many combinations and nothing worked. I just tried what you suggested and it finally works. Thank you! – Hatem Jaber Feb 22 at 15:42

I had the same problem on a few servers since upgrading to Ubuntu 12.04. nfsvers=3 didn't resolve the issue for me. Adding

mount -a

to /etc/rc.local did though.

share|improve this answer

It might be because the IP address of the NFS server in your fstab file is different from the one you use via CLI...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.