Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed the latest version of Ubuntu with wubi, everything works fine, I installed the driver for my wireless card, works great, but I found this problem:

On Windows 7, if I turn off the wireless card, then turn off Windows 7, then boot Ubuntu, my wireless card won't work.

Is this normal? Is there a fix for this?

I have a Dell Inspiron 1440

share|improve this question
    
Try the "hardware" wireless switch, Fn+F2 keys. –  izx Jun 8 '12 at 19:22
    
Fn+F2 did nothing.... Also did more research in this topic and I'm not the only one with this issue. At the moment I'm unable to find a proper answer.Apparently I have to keep turned on my wireless on windows 7 in order to work on ubuntu.... this is pretty disappointing... –  Alejandro Jun 12 '12 at 13:43
    
I had the exact opposite on a HP netbook. The wifi was turned off in ubuntu, and windows couldn't make it work. I had to boot back to ubuntu, turn it on, the boot back to windows before wifi would work. –  Jazz Aug 8 '12 at 7:29
add comment

2 Answers 2

On Windows 7, if I turn off the wireless card, then turn off Windows 7, then boot Ubuntu, my wireless card won't work.

The proprietary drivers/software for your wireless card/laptop in Windows have a way of telling the wireless card to switch off. Unfortunately, it appears the open-source drivers in Ubuntu/Linux cannot.

The only solution is to not "turn off" the card before you shutdown Windows -- you don't need to do that anyway, it's not like the card will consume power once the laptop is shut down.

Apparently I have to keep turned on my wireless on windows 7 in order to work on ubuntu.... this is pretty disappointing

You can only use either Wubi-buntu OR Windows at any one time. I really don't understand what all the fuss is about.


What's the real solution?

Support wireless card manufacturers who provide proper Linux drivers or at least disclose enough information for the open-source community to write such drivers. Get a new mini-pcie wireless card; I recommend the Intel 6205/6230/6300 - works great with iwlwifi.

share|improve this answer
add comment

There may a setting in the BIOS that will help. I have noted settings that prevent the hardware switch working, and there may also be ways to enable/disable the wifi independent of the operating system.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.