Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04, and firefox 13. When I do google search in firefox, it changes from default English to local language. I can't find google.xml to change the language settings, and the google's language search settings don't hold the saved default language

share|improve this question
1  
Rohit, there's no need to mention thatyou still need help, especially only after your question is only 30 minutes old. please try to refrain from saying "I still need help", because a question that has not yet been marked as "Correct Answer"'d is assumed to still need help. –  Thomas W. Jun 8 '12 at 16:45
    
thanks for letting me know. I rarely post in here. So not sure how this post and reply of "askubuntu" works. –  Rohit Jun 8 '12 at 17:35
    
I'd recommend reading the FAQ then, if you're new here. –  Thomas W. Jun 11 '12 at 12:08

4 Answers 4

up vote 1 down vote accepted

To Change the language to English you'll have to do some work. Here's how.

The goal is to change Firefox default query string for Google searches.

Quoted from this site:

Making it stick

Each time you'll update Firefox, you will have to re-apply your changes to the XML file. So it is generally easier to just duplicate the google.xml file as for instance google_en.xml. In the new XML file, add the hl parameter, and change the name of the search engine. Then, in Firefox, select your new search engine. Being a custom search engine, it will not be erased by an update of Firefox.

share|improve this answer
    
I mentioned with this question that I am unable to find google.xml in my drive. Which specifies that the choice you gave through that link can't be performed. The location which should have google.xml doesn't exist. And I know about the link which you gave.This even mentioned in this link as well. But as I said google.xml isn't available. patrickmicka.com/ubuntu/… –  Rohit Jun 8 '12 at 17:17
    
@ Rohit -At the End of the Link , there is a mention of this Addon . Try that . –  atenz Jun 8 '12 at 17:58
    
@tijybba, Thanks, But it only works for search toolbar..Not for the type and search option –  Rohit Jun 8 '12 at 18:07
    
@Rohit -I got this and this :D –  atenz Jun 8 '12 at 18:18
    
you can find google.xml at /usr/lib/firefox/distribution/searchplugins/locale/en-US –  Mitch Jun 8 '12 at 18:24

After updating to version 13 , i got the same problem. If you got Google in hindi as local Lang try this

Seach term

Then after clicking that option ,select this menu

enter image description here

Which will take you to language selection Scrolling window , save your preferred Language from the bottom First click-able button.

P.S : Since most of the languages will have same Graphical Selection , so i posted in Screenshot Format.

share|improve this answer
    
I did that initially before posting here. But it never saves for my future searches when I do. Each time I have to save the same google's setting. And even as they mention in their google's site that to save the cookies in firefox, that too been done. Nothing working in here. It's so disgusting firefox i feel now –  Rohit Jun 8 '12 at 16:02

It's not a firefox specific issue, so stop feeling disgusted with firefox. Try some other browser, and it'll display the same behaviour. It's a change done by google, and not mozilla.

share|improve this answer

tijybba

It is a Firefox Specific, Please recheck yourself with chrome browser, google gives you out in english rather as firefox gives in Hindi

MSRVNA

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.