Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I run ntpdate on its own, I get the following output:

8 Jun 15:47:46 ntpdate[31251]: no servers can be used, exiting

If I run it with the -q ntp.ubuntu.com switch, it seems to query just fine.

I have been hunting through many files and the most relevant one I have found is /etc/default/ntpdate, however, even with NTPDATE_USE_CONF set to no, I just can't understand/see how this error is occurring

Any ideas?

Update--

It appears that ntpdate-debianworks fine and is the actual command that makes use of /etc/default/ntpdate, but this doesn't answer the main question and I still can't find it...

share|improve this question
    
Unresolved in: bugs.launchpad.net/ubuntu/+source/ntp/+bug/176844 –  david6 Jan 2 '13 at 2:09

2 Answers 2

up vote 12 down vote accepted

After mucking around for most of the day, I have come to the following conclusion:

ntpdate-debian is the version to use if you want to use a config script, and in that case, you would edit the /etc/default/ntupdate file.

ntpdate cannot be used without arguments nor does it have a config file. If you want to use this to update, you have to state the ntp server in an argument, such as ntpdate ntp.ubuntu.com.

share|improve this answer
    
I have two days left to accept my own answer... If no one else replies, I will accept this, but will happily switch over if you have anything better to add! –  wilhil Jun 8 '12 at 20:30

NTPDATE_USE_NTP_CONF refers to /etc/ntp.conf file as defined:

Set to "yes" to take the server list from /etc/ntp.conf, from package ntp, so you only have to keep it in one place.

Your error seems to be something temporary.

share|improve this answer
    
I am getting that error all the time, and, the file /etc/ntp.conf doesn't exist - I have tried a few different configs with the same result –  wilhil Jun 8 '12 at 15:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.