Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to setup my Ubuntu 12.04 with OpenCL(Open Computing Language) support for i7 2600k and Radeon HD5870.

My Monitor is connected to the integrated Graphics of the i7. Intel OpenCL SDK is installed and working. Iteration of avaliable OpenCL devices shows 2 entries for Intel.

As recommended I installed AMD APP SDK 2.6 first and then the fglrx driver.

I installed fglrx from Ubuntu repositories. This works fine till here.

When I run

aticonfig --inital -f  

and restart the system I get into trouble.

Xorg starts only in low-graphics mode.

cat /var/log/Xorg.0.log
[    21.201] 
X.Org X Server 1.12.2
Release Date: 2012-05-29
[    21.201] X Protocol Version 11, Revision 0
[    21.201] Build Operating System: Linux 2.6.24-29-xen x86_64 Ubuntu
[    21.201] Current Operating System: Linux chimera 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012 x86_
[    21.201] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=c137757b-486b-4514-9dfe-00c97662
[    21.201] Build Date: 05 June 2012  08:35:55AM
[    21.201] xorg-server 2:1.12.2+git20120605+server-1.12-branch.aaf48906-0ubuntu0ricotz~precise (For technical suppor
[    21.201] Current version of pixman: 0.26.0
[    21.201]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[    21.201] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    21.201] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jun  8 14:22:36 2012
[    21.247] (==) Using config file: "/etc/X11/xorg.conf"
[    21.247] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    21.450] (==) ServerLayout "aticonfig Layout"
[    21.450] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[    21.450] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[    21.451] (**) |   |-->Device "aticonfig-Device[0]-0"
[    21.451] (==) Automatically adding devices
[    21.451] (==) Automatically enabling devices
[    21.466] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    21.466]    Entry deleted from font path.
[    21.466] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    21.466]    Entry deleted from font path.
[    21.466] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    21.466]    Entry deleted from font path.
[    21.473] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    21.473]    Entry deleted from font path.
[    21.473] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    21.473]    Entry deleted from font path.
[    21.473] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[    21.473]    Entry deleted from font path.
[    21.473] (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/Type1,
    built-ins
[    21.473] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib
[    21.473] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[    21.473] (II) Loader magic: 0x7f0ad3b9ab00
[    21.473] (II) Module ABI versions:
[    21.473]    X.Org ANSI C Emulation: 0.4
[    21.473]    X.Org Video Driver: 12.0
[    21.473]    X.Org XInput driver : 16.0
[    21.473]    X.Org Server Extension : 6.0
[    21.473] (--) PCI:*(0:0:2:0) 8086:0122:1458:d000 rev 9, Mem @ 0xfb800000/4194304, 0xe0000000/268435456, I/O @ 0x00
[    21.473] (--) PCI: (0:1:0:0) 1002:6898:1787:2289 rev 0, Mem @ 0xd0000000/268435456, 0xfbdc0000/131072, I/O @ 0x000
[    21.473] (II) Open ACPI successful (/var/run/acpid.socket)
[    21.473] (II) "extmod" will be loaded by default.
[    21.473] (II) "dbe" will be loaded by default.
[    21.473] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    21.473] (II) "record" will be loaded by default.
[    21.473] (II) "dri" will be loaded by default.
[    21.473] (II) "dri2" will be loaded by default.
[    21.473] (II) LoadModule: "glx"
[    21.732] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/extensions/libgl
[    21.934] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[    21.934]    compiled for 6.9.0, module version = 1.0.0
[    21.934] (II) Loading extension GLX
[    21.934] (II) LoadModule: "extmod"
[    22.028] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[    22.041] (II) Module extmod: vendor="X.Org Foundation"
[    22.041]    compiled for 1.12.2, module version = 1.0.0
[    22.041]    Module class: X.Org Server Extension
[    22.041]    ABI class: X.Org Server Extension, version 6.0
[    22.041] (II) Loading extension MIT-SCREEN-SAVER
[    22.041] (II) Loading extension XFree86-VidModeExtension
[    22.041] (II) Loading extension XFree86-DGA
[    22.041] (II) Loading extension DPMS
[    22.041] (II) Loading extension XVideo
[    22.041] (II) Loading extension XVideo-MotionCompensation
[    22.041] (II) Loading extension X-Resource
[    22.041] (II) LoadModule: "dbe"
[    22.041] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[    22.066] (II) Module dbe: vendor="X.Org Foundation"
[    22.066]    compiled for 1.12.2, module version = 1.0.0
[    22.066]    Module class: X.Org Server Extension
[    22.066]    ABI class: X.Org Server Extension, version 6.0
[    22.066] (II) Loading extension DOUBLE-BUFFER
[    22.066] (II) LoadModule: "record"
[    22.066] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[    22.077] (II) Module record: vendor="X.Org Foundation"
[    22.077]    compiled for 1.12.2, module version = 1.13.0
[    22.077]    Module class: X.Org Server Extension
[    22.077]    ABI class: X.Org Server Extension, version 6.0
[    22.077] (II) Loading extension RECORD
[    22.077] (II) LoadModule: "dri"
[    22.077] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[    22.082] (II) Module dri: vendor="X.Org Foundation"
[    22.082]    compiled for 1.12.2, module version = 1.0.0
[    22.082]    ABI class: X.Org Server Extension, version 6.0
[    22.082] (II) Loading extension XFree86-DRI
[    22.082] (II) LoadModule: "dri2"
[    22.082] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[    22.083] (II) Module dri2: vendor="X.Org Foundation"
[    22.083]    compiled for 1.12.2, module version = 1.2.0
[    22.083]    ABI class: X.Org Server Extension, version 6.0
[    22.083] (II) Loading extension DRI2
[    22.083] (II) LoadModule: "fglrx"
[    22.083] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_dr
[    22.399] (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
[    22.399]    compiled for 1.4.99.906, module version = 8.96.4
[    22.399]    Module class: X.Org Video Driver
[    22.399] (II) Loading sub module "fglrxdrm"
[    22.399] (II) LoadModule: "fglrxdrm"
[    22.399] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/linux/libfglrxdr
[    22.445] (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
[    22.445]    compiled for 1.4.99.906, module version = 8.96.4
[    22.445] (II) ATI Proprietary Linux Driver Version Identifier:8.96.4
[    22.445] (II) ATI Proprietary Linux Driver Release Identifier: 8.96.7                               
[    22.445] (II) ATI Proprietary Linux Driver Build Date: Mar 12 2012 13:06:50
[    22.445] (++) using VT number 7

[    22.445] (WW) Falling back to old probe method for fglrx
[    23.043] (II) Loading PCS database from /etc/ati/amdpcsdb
[    23.082] (--) Chipset Supported AMD Graphics Processor (0x6898) found
[    23.107] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
[    23.107] (II) fglrx: intel VGA device detected, load intel driver.
[    23.107] (II) LoadModule: "intel"
[    23.211] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    23.475] (II) Module intel: vendor="X.Org Foundation"
[    23.475]    compiled for 1.12.2, module version = 2.19.0
[    23.475]    Module class: X.Org Video Driver
[    23.475]    ABI class: X.Org Video Driver, version 12.0
[    23.476] ukiDynamicMajor: found major device number 249
[    23.476] ukiDynamicMajor: found major device number 249
[    23.476] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    23.476] ukiOpenDevice: node name is /dev/ati/card0
[    23.476] ukiOpenDevice: open result is 8, (OK)
[    23.476] ukiOpenByBusid: ukiOpenMinor returns 8
[    23.476] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[    23.540] (WW) PowerXpress feature is not supported
[    23.540] (EE) No devices detected.
[    23.540] (==) Matched intel as autoconfigured driver 0
[    23.540] (==) Matched vesa as autoconfigured driver 1
[    23.540] (==) Matched fbdev as autoconfigured driver 2
[    23.540] (==) Assigned the driver to the xf86ConfigLayout
[    23.540] (II) LoadModule: "intel"
[    23.540] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    23.540] (II) Module intel: vendor="X.Org Foundation"
[    23.540]    compiled for 1.12.2, module version = 2.19.0
[    23.540]    Module class: X.Org Video Driver
[    23.540]    ABI class: X.Org Video Driver, version 12.0
[    23.540] (II) UnloadModule: "intel"
[    23.540] (II) Unloading intel
[    23.540] (II) Failed to load module "intel" (already loaded, 32522)
[    23.540] (II) LoadModule: "vesa"
[    23.583] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    23.620] (II) Module vesa: vendor="X.Org Foundation"
[    23.620]    compiled for 1.12.2, module version = 2.3.1
[    23.620]    Module class: X.Org Video Driver
[    23.620]    ABI class: X.Org Video Driver, version 12.0
[    23.620] (II) LoadModule: "fbdev"
[    23.620] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    23.661] (II) Module fbdev: vendor="X.Org Foundation"
[    23.661]    compiled for 1.12.2, module version = 0.4.2
[    23.661]    Module class: X.Org Video Driver
[    23.661]    ABI class: X.Org Video Driver, version 12.0
[    23.661] (II) ATI Proprietary Linux Driver Version Identifier:8.96.4
[    23.661] (II) ATI Proprietary Linux Driver Release Identifier: 8.96.7                               
[    23.661] (II) ATI Proprietary Linux Driver Build Date: Mar 12 2012 13:06:50
[    23.661] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
    i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
    E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
    965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
    4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
    Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
    Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
    Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
    Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
    Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server,
    Ivybridge Server (GT2)
[    23.661] (II) VESA: driver for VESA chipsets: vesa
[    23.661] (II) FBDEV: driver for framebuffer: fbdev
[    23.661] (++) using VT number 7

[    23.661] (WW) xf86OpenConsole: setpgid failed: Operation not permitted
[    23.661] (WW) xf86OpenConsole: setsid failed: Operation not permitted
[    23.661] (WW) Falling back to old probe method for fglrx
[    23.661] (II) Loading PCS database from /etc/ati/amdpcsdb
[    23.661] (WW) Falling back to old probe method for vesa
[    23.661] (WW) Falling back to old probe method for fbdev
[    23.661] (EE) No devices detected.
[    23.661] 
Fatal server error:
[    23.661] no screens found
[    23.661] 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[    23.661] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    23.661] 

xorg.conf:

cat /etc/X11/xorg.conf
Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
    Load  "glx"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Is there a way to get the Radeon to work in a hybrid configuration

or to use the Radeon as an OpenCL only device?


I tried the new Catalayst Beta (12.06) and got the following error:

cat /var/log/Xorg.0.log
[    13.833] 
X.Org X Server 1.12.2
Release Date: 2012-05-29
[    13.833] X Protocol Version 11, Revision 0
[    13.833] Build Operating System: Linux 2.6.24-29-xen x86_64 Ubuntu
[    13.833] Current Operating System: Linux chimera 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012 x86_64
[    13.833] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=c137757b-486b-4514-9dfe-00c97662cc0d ro quiet splash vt.handoff=7
[    13.833] Build Date: 05 June 2012  08:35:55AM
[    13.833] xorg-server 2:1.12.2+git20120605+server-1.12-branch.aaf48906-0ubuntu0ricotz~precise (For technical support please see http://www.ubuntu.com/support) 
[    13.833] Current version of pixman: 0.26.0
[    13.833]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[    13.833] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    13.833] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun 13 13:43:13 2012
[    13.833] (==) Using config file: "/etc/X11/xorg.conf"
[    13.833] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    13.986] (==) ServerLayout "aticonfig Layout"
[    13.986] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[    13.986] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[    13.986] (**) |   |-->Device "aticonfig-Device[0]-0"
[    13.986] (==) Automatically adding devices
[    13.986] (==) Automatically enabling devices
[    14.134] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    14.134]    Entry deleted from font path.
[    14.134] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    14.134]    Entry deleted from font path.
[    14.134] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    14.134]    Entry deleted from font path.
[    14.166] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    14.166]    Entry deleted from font path.
[    14.166] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    14.166]    Entry deleted from font path.
[    14.166] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[    14.166]    Entry deleted from font path.
[    14.166] (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/Type1,
    built-ins
[    14.166] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[    14.166] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[    14.166] (II) Loader magic: 0x7fbe0fafbb00
[    14.166] (II) Module ABI versions:
[    14.166]    X.Org ANSI C Emulation: 0.4
[    14.166]    X.Org Video Driver: 12.0
[    14.166]    X.Org XInput driver : 16.0
[    14.166]    X.Org Server Extension : 6.0
[    14.166] (--) PCI: (0:0:2:0) 8086:0122:1458:d000 rev 9, Mem @ 0xfb800000/4194304, 0xe0000000/268435456, I/O @ 0x0000ff00/64
[    14.166] (--) PCI:*(0:1:0:0) 1002:6898:1787:2289 rev 0, Mem @ 0xd0000000/268435456, 0xfbdc0000/131072, I/O @ 0x0000ee00/256, BIOS @ 0x????????/131072
[    14.166] (II) Open ACPI successful (/var/run/acpid.socket)
[    14.166] (II) "extmod" will be loaded by default.
[    14.166] (II) "dbe" will be loaded by default.
[    14.166] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    14.166] (II) "record" will be loaded by default.
[    14.166] (II) "dri" will be loaded by default.
[    14.166] (II) "dri2" will be loaded by default.
[    14.166] (II) LoadModule: "glx"
[    14.188] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/extensions/libglx.so
[    14.188] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[    14.188]    compiled for 6.9.0, module version = 1.0.0
[    14.188] (II) Loading extension GLX
[    14.188] (II) LoadModule: "extmod"
[    14.466] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[    14.475] (II) Module extmod: vendor="X.Org Foundation"
[    14.475]    compiled for 1.12.2, module version = 1.0.0
[    14.475]    Module class: X.Org Server Extension
[    14.475]    ABI class: X.Org Server Extension, version 6.0
[    14.475] (II) Loading extension MIT-SCREEN-SAVER
[    14.475] (II) Loading extension XFree86-VidModeExtension
[    14.475] (II) Loading extension XFree86-DGA
[    14.475] (II) Loading extension DPMS
[    14.475] (II) Loading extension XVideo
[    14.475] (II) Loading extension XVideo-MotionCompensation
[    14.475] (II) Loading extension X-Resource
[    14.475] (II) LoadModule: "dbe"
[    14.475] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[    14.475] (II) Module dbe: vendor="X.Org Foundation"
[    14.475]    compiled for 1.12.2, module version = 1.0.0
[    14.475]    Module class: X.Org Server Extension
[    14.475]    ABI class: X.Org Server Extension, version 6.0
[    14.475] (II) Loading extension DOUBLE-BUFFER
[    14.475] (II) LoadModule: "record"
[    14.475] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[    14.475] (II) Module record: vendor="X.Org Foundation"
[    14.475]    compiled for 1.12.2, module version = 1.13.0
[    14.475]    Module class: X.Org Server Extension
[    14.475]    ABI class: X.Org Server Extension, version 6.0
[    14.475] (II) Loading extension RECORD
[    14.475] (II) LoadModule: "dri"
[    14.476] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[    14.476] (II) Module dri: vendor="X.Org Foundation"
[    14.476]    compiled for 1.12.2, module version = 1.0.0
[    14.476]    ABI class: X.Org Server Extension, version 6.0
[    14.476] (II) Loading extension XFree86-DRI
[    14.476] (II) LoadModule: "dri2"
[    14.476] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[    14.476] (II) Module dri2: vendor="X.Org Foundation"
[    14.476]    compiled for 1.12.2, module version = 1.2.0
[    14.476]    ABI class: X.Org Server Extension, version 6.0
[    14.476] (II) Loading extension DRI2
[    14.476] (II) LoadModule: "fglrx"
[    14.476] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so
[    15.256] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[    15.256]    compiled for 1.4.99.906, module version = 8.98.2
[    15.256]    Module class: X.Org Video Driver
[    15.257] (II) Loading sub module "fglrxdrm"
[    15.257] (II) LoadModule: "fglrxdrm"
[    15.257] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/linux/libfglrxdrm.so
[    15.354] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    15.354]    compiled for 1.4.99.906, module version = 8.98.2
[    15.354] (II) AMD Proprietary Linux Driver Version Identifier:8.98.2
[    15.354] (II) AMD Proprietary Linux Driver Release Identifier: UNSUPPORTED-8.98                     
[    15.354] (II) AMD Proprietary Linux Driver Build Date: May 22 2012 21:15:05
[    15.354] (++) using VT number 7

[    15.354] (WW) Falling back to old probe method for fglrx
[    15.499] (II) Loading PCS database from /etc/ati/amdpcsdb
[    15.502] (WW) Unsupported ASIC ID 1002:9403:0000:0000 in control file
[    15.502] (WW) Unsupported ASIC ID 1002:9403:0000:0000 in control file
[    15.502] (WW) Unsupported ASIC ID 1002:9400:0000:0000 in control file
[    15.502] (WW) Unsupported ASIC ID 1002:9400:0000:0000 in control file
[    15.502] (II) AMD ASIC control file status: R4 S0 B208 N312 T207
[    15.502] (--) Chipset Supported AMD Graphics Processor (0x6898) found
[    15.510] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
[    15.510] (II) AMD Video driver is running on a device belonging to a group targeted for this release
[    15.511] (II) AMD Video driver is unsigned
[    15.511] (II) fglrx(0): pEnt->device->identifier=0x7fbe10444000
[    15.511] (II) fglrx(0): === [xdl_xs112_atiddxPreInit] === begin
[    15.511] (II) Loading sub module "vgahw"
[    15.511] (II) LoadModule: "vgahw"
[    15.511] (II) Loading /usr/lib/xorg/modules/libvgahw.so
[    15.518] (II) Module vgahw: vendor="X.Org Foundation"
[    15.518]    compiled for 1.12.2, module version = 0.1.0
[    15.518]    ABI class: X.Org Video Driver, version 12.0
[    15.518] (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
[    15.518] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[    15.518] (==) fglrx(0): Default visual is TrueColor
[    15.518] (**) fglrx(0): Option "DPMS" "true"
[    15.518] (==) fglrx(0): RGB weight 888
[    15.518] (II) fglrx(0): Using 8 bits per RGB 
[    15.518] (==) fglrx(0): Buffer Tiling is ON
[    15.518] (II) Loading sub module "fglrxdrm"
[    15.518] (II) LoadModule: "fglrxdrm"
[    15.518] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/linux/libfglrxdrm.so
[    15.518] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    15.518]    compiled for 1.4.99.906, module version = 8.98.2
[    15.519] ukiDynamicMajor: found major device number 249
[    15.519] ukiDynamicMajor: found major device number 249
[    15.519] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    15.519] ukiOpenDevice: node name is /dev/ati/card0
[    15.519] ukiOpenDevice: open result is 12, (OK)
[    15.519] ukiOpenByBusid: ukiOpenMinor returns 12
[    15.519] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[    15.519] (**) fglrx(0): NoAccel = NO
[    15.519] (**) fglrx(0): AMD 2D Acceleration Architecture enabled
[    15.519] (--) fglrx(0): Chipset: "ATI Radeon HD 5800 Series" (Chipset = 0x6898)
[    15.519] (--) fglrx(0): (PciSubVendor = 0x1787, PciSubDevice = 0x2289)
[    15.519] (==) fglrx(0): board vendor info: third party graphics adapter - NOT original AMD
[    15.519] (--) fglrx(0): Linear framebuffer (phys) at 0xd0000000
[    15.519] (--) fglrx(0): MMIO registers at 0xfbdc0000
[    15.519] (--) fglrx(0): I/O port at 0x0000ee00
[    15.519] (==) fglrx(0): ROM-BIOS at 0x000c0000
[    15.532] (II) fglrx(0): AC Adapter is used
[    15.538] 
[    15.538] Backtrace:
[    15.550] 0: /usr/bin/X (xorg_backtrace+0x34) [0x7fbe0f891384]
[    15.550] 1: /usr/bin/X (0x7fbe0f70b000+0x18a16a) [0x7fbe0f89516a]
[    15.550] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7fbe0ea31000+0xfcb0) [0x7fbe0ea40cb0]
[    15.550] 3: /usr/lib/x86_64-linux-gnu/libpciaccess.so.0 (0x7fbe0ec4e000+0x4dd4) [0x7fbe0ec52dd4]
[    15.550] 4: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so (0x7fbe0aeba000+0x8032c9) [0x7fbe0b6bd2c9]
[    15.550] 5: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so (amd_xs112_int10_xf86ExtendedInitInt10+0xdd) [0x7fbe0b6bd05d]
[    15.550] 6: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so (amd_xs112_int10_xf86InitInt10+0xb) [0x7fbe0b6bc8fb]
[    15.550] 7: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so (xf86InitInt10+0xd) [0x7fbe0b20297d]
[    15.550] 8: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so (0x7fbe0aeba000+0x48405c) [0x7fbe0b33e05c]
[    15.550] 9: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so (xdl_xs112_PreInitAdapter+0x274) [0x7fbe0b33dc34]
[    15.550] 10: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so (xdl_xs112_atiddxPreInit+0x12ad) [0x7fbe0b33f31d]
[    15.550] 11: /usr/bin/X (InitOutput+0x9c8) [0x7fbe0f79a058]
[    15.551] 12: /usr/bin/X (0x7fbe0f70b000+0x3d6dd) [0x7fbe0f7486dd]
[    15.551] 13: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xed) [0x7fbe0d8c676d]
[    15.551] 14: /usr/bin/X (0x7fbe0f70b000+0x3db9d) [0x7fbe0f748b9d]
[    15.551] 
[    15.551] Segmentation fault at address 0x10448c12
[    15.551] 
Caught signal 11 (Segmentation fault). Server aborting
[    15.551] 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[    15.551] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    15.551] 
[    15.661]  ddxSigGiveUp: Closing log
[    15.661] Server terminated with error (1). Closing log file.

Does anyone know how to fix it?

share|improve this question
    
I got the same problem with my hp dv-6 3160so, HD 5650. Seams like most people with hd 5000 series graphic cards have this problem > Is there a way to get the Radeon to work in a hybrid configuration or to use the Radeon as an OpenCL only device? It works for some people: ubuntuforums.org/showthread.php?t=1930450 –  user69672 Jun 10 '12 at 10:36
    
I tested the steps suggested in the thread but as promised at the top of the thread this does not work for hd5xxx :( –  Steve Jun 10 '12 at 11:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.