Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing the program nod32 antivirus I took this error every time I open console.

ERROR: ld.so: object 'libesets_pac.so' from /etc/ld.so.preload cannot be preloaded: ignored.

I use X ubuntu 12.04

enter image description here

Any solution of this problem?

share|improve this question

4 Answers 4

up vote 2 down vote accepted

After installing the program nod32 antivirus in ubuntu 12.04 I got this error every time I opened the console.

ERROR: ld.so: object 'libesets_pac.so' from /etc/ld.so.preload cannot be preloaded: ignored.

You can try to do this (from this page in Russian):

  • Open /etc/ld.so.preload, open this well

    sudo nano -w /etc/ld.so.preload
    

    and delete the row libesetspac.so and save, after.

  • Open /etc/rc.local, open this well

    sudo nano -w /etc/rc.local
    

    and just enter the line /opt/eset/esets/sbin/esets_daemon and save, after restarting the system. Good luck--this should solve your problem.

share|improve this answer
    
In case the libesetspac.so was the only line in ld.so.preload should I leave the file empty? or delete the file? –  michel.iamit May 14 at 9:04

This seemed to have fixed that issue for me on Ubuntu 11.10 x64

sudo vi /etc/ld.so.preload

change libesets_pac.so to /opt/eset/esets/lib/libesets_pac.so

Save and your error should stop.

(Source)

share|improve this answer

From the preload message , I believe you're installing the wrong architecture.

But if you're on a x64 system , it's unavoidable , since you could be running 32bit programs as well , so esets installs both architecture , which made 64bits program can't preload the 32bit library , 32bit's program can't load 64bit library.

The only way to get rid of this , is make all your system 32bits.

share|improve this answer

I had a different problem altogether. It wouldn't load lightdm, and then it wouldn't load gdm, so I installed XDM, and Gnome automatically crashed and would not send the bug reports. This was with 64bit on 64bit Ubuntu 12.04, and what it did was fun.

I don't normally run Gnome because it bogs down a bit, so I removed nearly everything involving Gnome, and it runs now with some problems. GNU/Step or Icewm now.

I also had to remove the default network-management packages. I never saw the ldconfig related error. I then updated /etc/network/interfaces to auto load my webz and it worked.

I figured it may have something to do with configuration files, but I just wanted the dang thing to work. And I don't like XFCE, Gnome, KDE anymore. The installation of any of them is nearly the capacity of a CD-ROM.

It's not so much the problems with ESET as it is some of the programs looking for things they can't find, even though they have their dependencies. For instance, I can no longer upload files from Firefox. And the changing the ld configuration did not help, I tried that after I read that. And installed KDE and KDM, KDM didn't crash, but I got the ldconfig error that I should get before I edited the ld file.

And you know I'm on firefox 64bit as we speak, and I tried to send as many bug reports as I could, but... it only sent the same ones. I sent log files to ESET on Monday, now I have more.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.