Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently installed Xubuntu 12.04 alongside Windows Vista on my Acer Aspire 6920G laptop. I installed the latest proprietary fglrx drivers for the ATI radeon mobility 3650.

In Xubuntu I felt significant heat coming from the area in which the graphics card is situated, even when the system is idle. After about 10 minutes of playing Quake Live the system shut down suddenly. I opened up the laptop and found that the reason for the emergency shut down was most likely the graphics card, as the heat sink was extremely hot. The heat sink for the CPU wasn't hot and I vacuumed it recently (and temperatures are within normal range) So I have assumed it isn't the CPU.

I vacuumed the laptop again and booted into Windows. When the system is idle the laptop feels warmish but significantly cooler where the graphics card is situated. After playing UT2004 and Quake Live for a good while I found that even though the graphics card got warmer, the computer never shut down.

Has anyone else had this problem and does anyone know why the graphics card overheats in Xubuntu and not Windows (if that is indeed the cause)? How can I find out what exactly is causing this problem? is it a power-management issue or graphics drivers issue? I installed Xubuntu to have a less resource intensive system but I might have to go back to Windows for fear of overheating and emergency shut downs.

Additional Info:

One thing I also noticed was that UT2004 runs with lower frame rate and has to have less demanding graphics settings to run more smoothly in Xubuntu. In Windows I can have very high graphics settings and it runs very smoothly. So perhaps the route of the problem is the drivers. However, the fan/system-in-general seems much noisier in Xubuntu, even when idle, although the CPU usage doesn't seem any higher.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Right it seems that the command aticonfig --initial initialized the /etc/X11/xorg.conf file and filled it with the correct configuration for my graphics card. Before I did this the file had almost no information in it so if anyone has a similar problem check that /etc/X11/xorg.conf is set up correctly (might be in a different folder for others). I played UT2004 after doing this and the frame rate issue is gone, even on higher settings. Although the graphics card got hotter there was no emergency shut down and I played it for a while.

If you want a way to check if the file is set up correctly run aticonfig --odgc --odgt --adapter=all (this was suggested in Bill's answer so credit goes to him). This command normally returns performance information about your graphics card. If /etc/X11/xorg.conf isn't set up correctly it will return an error that asks you to run aticonfig --initial.

share|improve this answer
    
Following your advice, I'm stuck with the error message ERROR - Get temperature failed for Adapter 0 - ATI Mobility Radeon HD 3650 –  r.bitter Aug 24 '12 at 8:50
    
I also get this error and I never figured out why. UT2004 runs fine despite the fact that this error is given. But I honestly don't know what causes it. Perhaps this issue alone would make for a good question to ask. –  Jonathan Aug 27 '12 at 19:26
    
I've read somewhere that the Thinkpad T500 does not have a temperature sensor for the GPU, which explains the error message. –  r.bitter Aug 27 '12 at 19:33
  • Have you installed the most recent drivers on card?
  • Does this happen when the battery is plugged in? or out?
  • Have you checked how stressed the GPU is?

aticonfig --odgc --odgt --adapter=all

This command should display the stress being put on GPU. The memory and GPU usage will appear in percentage. Also it will give you your fan speed to see if that is changing while the GPU is being heavily stressed.

Try running that as you play Quake on linux machine and compare results with what its doing while on Windows. It may well just be that your linux machine is not controlling the fan as it becomes more stressed. But more likely this is a drivers problem.

Bill

share|improve this answer
    
Hi, thanks for the reply, when I type that command in I get this message - No layout section was found in the file: '/etc/X11/xorg.conf'. Please run 'aticonfig --initial' first or modify your configuration file manually and run aticonfig again. aticonfig: parsing the command-line failed. –  Jonathan Jun 8 '12 at 9:07
    
I then tried "aticonfig --initial" but got this - Uninitialised file found, configuring. Using /etc/X11/xorg.conf Saving back-up to /etc/X11/xorg.conf.original-0. Is there something else I need installed to run this program? –  Jonathan Jun 8 '12 at 9:09
    
After trying that a couple of times it started working now! However it says GPU load is 0% and it also says Get temperature failed for Adapter 0 - ATI Mobility Radeon HD 3650. –  Jonathan Jun 8 '12 at 9:19
    
Have you made sure you are on the new driver for ATI? Install that then, Once you have done that run the "aticonfig --initial" again. I think the problem is that the wrong drivers are installed and that it wont pick up the temperature or have control of the fans. And the GPU is just overheating under load.. If its not that then im out of answers mate sorry. –  LinuxBill Jun 8 '12 at 9:38
    
Hey see my answer. Your answer lead me to it but I can't upvote yet. But thanks a lot for your help! –  Jonathan Jun 9 '12 at 11:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.