Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to create a Ubuntu 12.04 Live CD. So I open Startup Disk Creator in the Ubuntu Dash. I go through all of the settings, and then click 'Make Startup Disk'.

Make Startup Disk

Almost immediately I get a window that only says 'Installation Failed'.

Installation Failed

I tried it again, and got the same result. I even downloaded a new copy of the .ISO file from the Ubuntu website. Sadly, the same thing happened.

How may I avoid this issue? Thanks in advance!

share|improve this question
Try clicking the Erase Disk button first. That will delete everything from that device, so make sure there is nothing important. – mikewhatever Jun 8 '12 at 1:02
I did, several times. Thanks though. – TriforceLZG Jun 10 '12 at 4:53
can you tell what error's are coming – Creator Jun 14 '14 at 15:47

Try formatting the USB stick with a FAT32 filesystem and try again. That should do the trick.

share|improve this answer

format the drive to FAT 32 file system then

use terminal first get the correct device address like (dev/sdb)

to get all memory location addresses df

get the correct location of flash drive and type following command sudo dd if=input.iso of=/dev/sdc

see this if you want more details

How to create a bootable Ubuntu USB flash drive from terminal?

share|improve this answer

A possible reason for this error is the inability to access the ISO file. For instance, if the user can list the contents of the directory containing the ISO, but not read the file itself, Startup Disk Creator will let select the file, and then fail with "Installation failed." error.

It is surprising that this case was not handled by the tool, for example by showing a more descriptive error message.

share|improve this answer

I faced many USB problem while making it bootable or during formatting. I had the same problem too. But in many cases, i solved just by restarting the system.

Remove USB, restart system , format it with FAT32 and then make it bootable.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.