Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 by doing a fresh install where there was previously Ubuntu 11.10. My computer warns me now that my disk is nearly full. After having run apt-get purge, run apt-get autoremove and emptied the Trash can, I still have this problem as shown by this screenshot of Gparted: gparted screenshot

The disk /dev/sda7 is indeed full. I ran the Disk Usage Analyzer (Baobab) and I am still not sure of what is happening: baobab screenshot

One of my hypothesis is that when installing Ubuntu 12.04, I didn't configure my disks well and the disk /dev/sda6 is not mounted well as /home. Is this the reason indeed? What should I do to verify this and then to get the things fixed?


Here are a few additional details to answer the questions I received (thank you everybody):

  • My home directory is not encrypted.
  • The Backup utility (Déjà Dup) is not set for automatic backups. (I do it myself and manually.)
  • After I mount /dev/sda6, the command df -h gives

    Filesystem Size Used Avail Use% Mounted on

    /dev/sda7 244G 221G 12G 96% /

    udev 3,9G 4,0K 3,9G 1% /dev

    tmpfs 1,6G 904K 1,6G 1% /run

    none 5,0M 0 5,0M 0% /run/lock

    none 3,9G 164K 3,9G 1% /run/shm

    /dev/sda6 653G 189G 433G 31% /media/8ec2fa69-039b-4c52-ab1b-034d785132a1

(sorry but formatting this into code does not work, for an unknown reason)

  • Thanks to izx's post, I realized /dev/sda6 was not even mounted before. It contains all the documents I used to have when I was running Ubuntu 11.10.
share|improve this question
2  
Drill down on the directories using the arrows on the left. That should provide some more light. –  reverendj1 Jun 7 '12 at 21:32
    
One potential gotcha I experienced is if you've set a deja-dup backup directory in Ubuntu One as 'always in sync' ‒ that can lead to a copy of your whole home directory being downloaded into your home directory, which then gets backed up and downloaded again! If you're using deja-dup and find backing up really slow see if that setting is enabled. –  Garry Cairns Jun 7 '12 at 21:35
    
Whats the output of the command df -h? It looks like /dev/sda6 has not been mounted as /home, if that is what you intended. If this is the case it is an easy fix, but you will need to move anything you have saved in /home since installing 12.04 because you need an empty directory to mount a partition/disk there. –  cosmorogers Jun 7 '12 at 21:50
    
Is /home encrypted? –  jrg Jun 7 '12 at 21:56

1 Answer 1

up vote 8 down vote accepted

One of my hypothesis is that when installing Ubuntu 12.04, I didn't configure my disks well and the disk /dev/sda6 is not mounted well as /home. Is this the reason indeed?

Yes!

What should I do to verify this

gparted clearly shows that /dev/sda6, although it contains some data, is NOT mounted as /home (or as anything).

and then to get the things fixed?

Outline: You would temporarily mount /dev/sda6, clean it up (or just format it, if the existing data doesn't matter), copy everything in your /home to it, unmount it and then set up /etc/fstab to mount it as /home from then on. Then reboot...

Official Guide on moving your home directory

Please follow this official guide which explains the process in more detail, and ask us any questions or concerns you may have in the comments.


As @jrg indicates in the comments though, if your /home is encrypted things get a little more complicated. Please ask a new question mentioning that in the title if you are in this situation.

share|improve this answer
    
I followed the guide: it is of excellent quality. All things were fine. Except three minor things that appeared when I checked if copying worked with diff: my weather indicator had updated its status, a lot of files had been updated due to Ubuntu One, and finally I had a line that reported differences: diff -r /home/agmenor/.gconf/apps/gedit-2/plugins/%gconf.xml /media/home/agmenor/.gconf/apps/gedit-2/plugins/%gconf.xml. More details here: paste.ubuntu.com/1030963 –  Agmenor Jun 8 '12 at 19:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.