Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i have 12.04 , ubuntu, and startup diskcreator isn't allowing the program to see the iso. root perms it just doesn't load it. the usb loads fine though.

share|improve this question

2 Answers 2

If the .iso file was downloaded as by root for some reason it could be unreadable by your regular account. You can open a terminal with Ctrl+Alt+T and enter the commandsudo chmod a+r the-image.iso to fix that.

I assume you are using usb-creator-gtk, the standard Ubuntu tool for this. I've had some trouble selecting the iso file I want with that program because of the small window available to select files. Let me suggest starting it from a terminal by using

usb-creator-gtk -i the-image.iso
share|improve this answer
    
If I misunderstand what is going on, please add the command you are using and the exact error message you are getting. –  John S Gruber Jun 7 '12 at 21:43
1  
I tried that, but didn't work, i'm not getting any error at cmd line, and nothing in the logs. –  kmassada Dec 3 '12 at 12:13
    
sudo usb-creator-gtk -i the-image.iso did the trick for me... :-) –  elviejo Apr 11 '13 at 18:51

This was solved for me by removing any .img files from the folder where the desired Ubuntu iso is located. So basically, I had an Android boot.img inside the same folder as the Ubuntu 12.04.1 iso, which is what I wanted to use for startup-disk-creator. I moved the boot.img to a separate folder, re-opened startup-disk-creator, and it worked. I don't know if it's a quirk with specifically choosing img files over iso files; or if there is a general issue with having two or more startup-disk compatible files inside the same folder, I just know that isolating the Ubuntu iso from other types of startup files solved the issue for me.

share|improve this answer
    
A strange error if true - it would need to be reported as a bug since it shouldn't matter if there are .img files in the same folder. –  fabricator4 Dec 8 '12 at 20:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.