Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Are you sure you want to close all programs and shut down the computer?

When I click shut down I want to shut down! :) This message bugs me. How to avoid this message?

share|improve this question
1  
I am looking for an answer for 12.04 –  vrcmr Jul 20 '12 at 21:16
2  
Verified answer for 11.10 works for 12.04, edited answer to include 12.04 in title. –  James Jul 20 '12 at 22:23

9 Answers 9

up vote 19 down vote accepted

For 12.04 an later

Settings for the indicator session and logout menu are found by running dconf-editor (from dconf-tools Install dconf-tools)

enter image description here

share|improve this answer
  • press Alt+F2 and type gconf-editor
  • go to /apps/indicator-session and check items you want
share|improve this answer

11.04 and previous versions of ubuntu

  • Alt + F2 and enter this: gconf-editor
  • apps > indicator-session
  • select suppress_logout_restart_shutdown

alt text

OR

  • Alt + F2 and enter this:

gconftool-2 --type bool --set /apps/indicator-session/suppress_logout_restart_shutdown true

To re-enable confirmation, replace the keyword true with false

share|improve this answer

For 10.04

Use CtrlAltDel, wait 60s or Enter.

No mouse involved - but fastest way I know of.

For 11.10 and later

The above keys shortcut lead to the logout dialog only. To assign a keyboard shortcut to the power off dialog we open

gnome-control-center keyboard

or Keyboard from System Settings... to define a new Custom Shortcut for the command

gnome-session-quit --power-off

This will open the following shutdown window:

enter image description here

In case we want CtrlAltDel for this we may have to define another shortcut for System -> Log out first.

share|improve this answer
    
There's an option not to prompt the user: gnome-session-quit --power-off --force --no-prompt –  medigeek Jul 27 '12 at 18:01

For GNOME2 panel (10.04 LTS)

Add Logout Button to GNOME Panel.

enter image description here

This is 1 mouse click to start the 60s shutdown countdown (immediate shutdown involves another mouse clicks).

share|improve this answer

Open Terminal and type sudo chmod u+s /sbin/shutdown

Then, from that point forward, any user can just issue the command shutdown in a terminal.

share|improve this answer

If you have Ubuntu Tweak installed you can do this by selecting Session control from the left hand side list and tick the box Suppress the logout, restart and shutdown confirmation dialogue box.

Check this question for Ubuntu tweak installation

share|improve this answer
    
For me personally in 11.10 I tried half a dozen different posted fixes checking and un-checking things various config editors and Ubuntu-Tweak was the only thing that actually worked. In the current version it is under Tweaks > Session Control –  Dennis Nov 30 '11 at 2:11

Easy Pease.

Right click application menus.

Edit Menu.

GOTO - System Tools.

Click on "tick box" for the configuration editor.

Bingo.

Exit.

Applications, System Tools. configuration editor. // Apps - Indicator Session. Click the tick boxes to see exactly what they do and then untick them... and use this one.

/apps/indicator-session/suppress_logout_restart_shutdown

Suppress the dialog to confirm logout, restart and shutdown action. Whether or not to show confirmation dialogs for logout, restart and shutdown actions.

share|improve this answer

For Ubuntu 12.04 (Tested on 12.04, should also work on other versions)

Just open a terminal and run this command:

gsettings set com.canonical.indicator.session suppress-logout-restart-shutdown true

That's it. To re-enable just change the true to false.

The good thing about this is, You don't need to install dconf-tools, though it is better to install it, which will give you a graphical settings editor called dconf-editor to change many other features

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.