Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am an active user of workspaces in Ubuntu. Until recently, pressing Ctrl+Alt+D (show desktop) acted only on the current workspace.

For example, one might want to minimize the applications in the current workspace, open a file, and then bring some of them back. The current implementation works on all workspaces uniformly which is counter-intuitive to me. The reason for the existence of workspaces is the separation of logic -- one can have a browser open in one workspace, a text editor in another, a terminal in a third.

The current functionality goes against this idea. Is there a way to restrict the action of the show desktop command to a single workspace only?

share|improve this question
2  
(By default Ctrl+Super+D shows desktop; not Ctrl+Alt+D - at least in 12.04.) –  Jakob Jun 7 '12 at 19:09
    
I think my default key is different since I had upgraded from a previous version of Ubuntu. The functionality remains the same though. –  thenasko Jun 8 '12 at 17:27
    
Interesting, what window manager are you running? For me on 12.04 with Gnome 3 Fallback, Ctrl+Alt+D has exactly the functionality you want already (only minimize windows on the current workspace). So, this seems to be something in the window manager. Edit: Just saw question is tagged with unity, must be a setting or change there. –  computermacgyver Sep 6 '12 at 1:58
    
You may post it in launchpad. That would be a nice option for Unity. It may be a bug in Unity –  user91632 Sep 27 '12 at 14:59

1 Answer 1

There is a bug report about this for 12.04. The bug's status is Fix Committed, meaning the fix will only be available in the next release.

In the meantime I can only recommend gnome3. There ControlSuperd works as expected.
In case you want to give it a try:

sudo apt-get install gnome-shell

Restart, and at the login, choose GNOME (first in the list):

enter image description here

Where to find the show desktop keybinding:
open dconf-editor and navigate to schema org.gnome.desktop.wm.keybindings.
You should find a key named show-desktop with its current value.

share|improve this answer
    
I have 12.04 and it doesn't seem to work as you describe, instead I have all windows in all workspaces minimized. This makes sense because the name of the action set in Keyboard Shortcuts is Hide All Normal Windows, not Show Desktop. Where did you find the Show Desktop action? –  Dmitry Pashkevich Oct 12 '12 at 15:18
    
Is this using gnome-shell? Navigate to the keybindings in dconf-editor to check the setting. –  rosch Oct 17 '12 at 22:55
    
No, unity3d, regular ubuntu installation –  Dmitry Pashkevich Oct 18 '12 at 6:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.