Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just did this

VBoxManage export foo_to_be_export --output bar.ova

But then I forgot to setup the default path. However, it shows it's 100%. I couldn't find this image now.

I tried

sudo find / -name bar.ova
sudo find . -name bar.ova

and none finds anything.

The first one seems to take forever (8 mins already...) so I just stopped it.

Does anyone know the default path? How can I find out?

share|improve this question
1  
Run the export again, and see if it tell you anything. –  Mitch Jun 7 '12 at 18:22
    
On Export Appliance-> NameofVM -> Next your export path will be displayed, just cancel then and see if it's there. –  Takkat Jun 7 '12 at 18:36
    
Thanks. It is now in home directory. But the first one was not. It was missing... and also, the output was the same –  user1012451 Jun 7 '12 at 18:36
add comment

3 Answers 3

up vote 1 down vote accepted

Doing find on / will search everything on your computer, including any mounted drives. To prevent this from happening, run:

find / -xdev -name bar.ova

By the way, you only need to run it with sudo if you ran the VBoxManage --export ... command with sudo. Otherwise, it's extremely unlikely that VBoxManage could have created a file somewhere you can't read from. You'll get plenty of "access denied" messages running find on / without sudo ...but that's not really a problem. If you want to log the results (but not error messages) to a file in your home directory, you can do this:

find / -xdev -name bar.ova | tee -a ~/find-results.log

If you have a separate partition for /home (which only happens if you set it up that way when you install Ubuntu, or deliberately migrate /home to a separate partition after installation), then find on / with -xdev won't search /home (which contains your home directory). The simplest and easiest solution to this is to do a separate find operation on /home:

find /home -xdev -name bar.ova

Or just on your home directory in /home, if you don't think you could've put it in another user's home directory:

find ~ -xdev -name bar.ova

You may want to leave off -xdev in these cases, though it's possible you (or other users) have FUSE or GVFS shares mounted inside home directories. (It's also possible a file got saved into one of those shares...)

With -xdev, when running find on /, it will still take a while, but it will complete eventually.

Something else you may want to try is to run sudo updatedb, wait for that to finish, and then run locate bar.ova.

share|improve this answer
    
Thanks for the complete walk through with various commands here. I tried updatedb as well but it shows only one. I guess something went really bad that it is now missing. I guess for now I will give up on that. Thanks. –  user1012451 Jun 7 '12 at 19:16
add comment

When I used the example you've given, substituting one of my virtual box vms like so:

chris@4314-APPWP:~$ VBoxManage export "Ubuntu LTP" --output bar.ova

The bar.ova file was generated in my home directory.

chris@4314-APPWP:~$ ls -lah bar.ova 
-rw------- 1 chris chris 1.3G Jun  7 14:26 bar.ova
chris@4314-APPWP:~$ pwd
/home/chris
chris@4314-APPWP:~$

Hope this helps!

share|improve this answer
    
I tried it again and it is in home directory. But the one I did first time was missing. The image is 1.9GB, and we run backup on this machine. It will be a disaster to not find out if it has been created or not. Is there a better find/grep command that I am not familiar with that can trace down? I tried *.ova as well..... Thanks –  user1012451 Jun 7 '12 at 18:35
    
@user1012451 Besides \*.ova (because if there are .ova files in the current directory, the shell will expand *.ova into a space-delimited list of them, and then the output of find will be strictly limited to those files instead of any other .ova files anywhere) ...you can also try -iname instead of -name (in case there is differing capitalization in the filename or .ova suffix). –  Eliah Kagan Jun 7 '12 at 18:48
    
@itnet 7 Thank you for your help. –  user1012451 Jun 7 '12 at 19:16
add comment

To find a file that's lost somewhere on your filesystem, run the following commands.

sudo updatedb
locate filename.ext

Explanation

updatedb - Updates the database used by locate.
locate - You guessed it. It locates files.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.