Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having hard time trying to hibernate kubuntu 12.04 It doesn't hibernate. instead it goes to the lock screen only.

I checked the swap and it's 10G and active. I tried to hibernate using the command "sudo pm-hibernate" and it worked. but, I want a better fix without using commands.

Thanks a lot in advance :)

share|improve this question

1 Answer 1

up vote 2 down vote accepted

If hibernatian works by using sudo pm-hibernate command when you want to hibernate.

You can enable the hibernate option in the menus. To do that, use your favorite text editor to create /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla. Add the following to the file and save:

[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

Source: helpdeskgeek

share|improve this answer
    
The hibernate option is already enabled. but it just locks the screen without hibernation –  Elshaer Jun 7 '12 at 18:24
    
What Kubuntu release are you running? –  Mitch Jun 7 '12 at 18:29
    
I am running Kubuntu 12.04 –  Elshaer Jun 7 '12 at 21:50
    
"The document could not be saved, as it was not possible to write to /etc/polkit-1/localauthority/50-local.d/com.ubuntu.desktop.pkla. Check that you have write access to this file or that enough disk space is available." That's the message I get when I try this. Any help? I have 100 GB of space and I made sure I had permissions set to write. What am I supposed to do? –  user70350 Jun 13 '12 at 12:45
    
This should either be a question or a comment in the other answer. However, did you use sudo when editing the file? –  Dason Jun 13 '12 at 12:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.