Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I always could connect to my companys Microsoft Lync network which is based on SIP. There is an addon for Pidgin called pidgin-sipe. Everything worked fine unless the company changed something weird. Now I always get a Read Error when I want to connect.

The debug output shows the following:
http://fixee.org/paste/vmfb4sl/

Isn't it possible anymore to connect or is this an error of pidgin-sipe?

share|improve this question

3 Answers 3

up vote 5 down vote accepted

just add:

NSS_SSL_CBC_RANDOM_IV=0

to /etc/environment

and it will persist without you needing a non-standard startup script for pidgin.

share|improve this answer
    
Doesn't it have any impact on other applications? –  Michael Tanner Jul 11 '13 at 7:17

~$ export NSS_SSL_CBC_RANDOM_IV=0

~$ pidgin

Seems to do the trick, not sure exactly what it does. I need to read up on it.

Here is the bug traq for the issue: https://bugs.launchpad.net/ubuntu/+source/pidgin/+bug/950790

share|improve this answer
    
Thanks, this is great. I just created a custom script to start pidgin with this setting. Would be nice to hear from you if you know what this option does exactly. –  Michael Tanner Jun 10 '12 at 16:30
    
Thanks! it seems to solve the "Read error", but I still getting auth error. Did you have to configure something special? –  Guy Korland Aug 1 '12 at 9:18
3  
Note: You can avoid having to use a script by condensing this into one command: NSS_SSL_CBC_RANDOM_IV=0 pidgin –  BHSPitMonkey Aug 23 '12 at 17:44
    
Perfect! Works for Windows as well! (Add that into user environment) –  FractalSpace Apr 4 '13 at 14:12
    
Doesn't work for me. –  hippyjim Jun 20 '13 at 10:26

To get it working with how you normally start applications in Ubuntu, and not getting into the way of other programs, you can copy the pidgin's launcher to ~/.local/share/applications/ directory by issuing the following commands:

mkdir -p ~/.local/share/applications
cp /usr/share/applications/pidgin.desktop ~/.local/share/applications

Then edit the file with your favorite editor, e.g.

nano ~/.local/share/applications/pidgin.desktop

Replace the line Exec=/usr/bin/pidgin with the following:

Exec=env NSS_SSL_CBC_RANDOM_IV=0 /usr/bin/pidgin
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.