Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Kubuntu 12.04 installed on HP 430 Notebook PC. My problem is that when I press Super Key, nothing happened. Some of my Fn keys did not work either.

I have changed the Keyboard Model in System Settings>Hardware>Input Devices>Keyboard to Hewlett Packard Internet keyboard but doesn't seems to help. I have also Compiz-Config-Setting-Manager installed but I don't know how to make the right keyboard setting.

I would like to have the Super Key launch Start Menu Launcher as in MS-Windows, is it possible ...
Thanks for the help

share|improve this question
    
Have you tried Keyboard Shortcuts under system settings? –  Mitch Jun 7 '12 at 10:58
    
Yes, I've look to the System Settings>Global Keyboard Shortcuts>KDE Component:KWin but couldn't find any setting for Start Menu Launcher. I did find some other customization settings for hotkeys, e.g. I can set 'Show Desktop' with Meta+D combination. Any other suggestions mate? –  zigma80 Jun 7 '12 at 12:50
    
Have you tried custom shortcuts? –  Mitch Jun 7 '12 at 13:16
    
I've followed your step but I got two problems. First, the shortcut input didn't accept only one key (super key). It just show 'Meta+' and then disappear. I suppose that it wants me to make a combination key 'Meta+something'. Second, I didn't know what command/URL should I put in 'Action' form. I thought that it should refer to 'kickoff launcher' but I couldn't find any file named 'kickoff' in /usr/bin. I'm sorry, I'm a newb here ... –  zigma80 Jun 7 '12 at 14:10
    
(in Ubuntu 12.04) You need to tap 'fast enough' in order to get dash, since if your tap is too slow nothing happens. (and if it's slow enough, you see the shortcut thing) –  raindrop Aug 17 '13 at 1:46
add comment

1 Answer

I'm beginning see the picture here, an article explain that ..

The 'Windows Key' (as I call it), more properly known as the “meta key”, is simply a modifier (like Shift, Ctrl, & Alt) and not a key in its own right. This means that you cannot, without some lower level file hacking, stab the Windows Key alone and get it to open the launcher.

So this is how we do it :

  1. Right click on Kickoff (the KDE icon in the bottom left of your screen)
  2. Click “Application Launcher Settings”
  3. Select “Keyboard Shortcuts”
  4. Click the button and press your desired shortcut keycombo
  5. Done!

source : LINK

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.