Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

One month ago I updated (no fresh install) to 12.04.

Since then nautilus got extremely slow. When I open a folder that contains many subfolders I sometimes have to wait 4 seconds until everything is displayed. This has never been like that before, in previous versions I could always browse between my files extremely fast.

If I start nautilus with root-rights from a terminal, it does work perfectly.

I looked in "additional drivers" and changed from Nvidia current-version-update to the recommended drivers. This drastically increased the performance and speed of file browsing, unfortunately just for a couple of days. Now I am stuck again with the very slow Nautilus.

I also tried to install the latest nvidia driver like it was suggested here: Did not work at all.

Also when using the dash to try to find files it does not respond properly: does not find files or loads for ages until the file is displayed.

I am working on an Acer Notebook with

Intel® Core™ i5 CPU M 430 @ 2.27GHz × 4
GeForce GT 320M/PCIe/SSE2
64 Bit Ubuntu 12.04

share|improve this question
Can you start nautilus from the command line, browse some folder with lots of files, and report back any messages errors? – Javier Rivera Jun 7 '12 at 9:26
If I open nautilus through a terminal ("sudo nautilus") file browsing works fluently. However I get the following error report in the terminal: ** (soffice:16051): CRITICAL **: murrine_style_draw_box: assertion `height >= -1' failed ** (soffice:16051): WARNING **: Couldn't call /com/canonical/AppMenu/Registrar.UnregisterWindow – Tobelli Jun 7 '12 at 11:18
Doing 'sudo nautilus' will start it with the root profile, it will hide any errors in your own one. As a curiosity, global menu is disable when you start it with sudo. Try 'killall nautilus;nautilus', to avoid just opening a new instance. – Javier Rivera Jun 7 '12 at 13:44
Thanks for helpling me out, I really appreciate it. Indeed the global menu is disabled when I do sudo nautilus – Tobelli Jun 7 '12 at 16:44
The issue still persists. Does anyone have a solution for this problem? – Tobelli Jun 10 '12 at 9:50

I figured out some ways to speed up nautilus: bookmarks and previews. But it's still not as fast as it should be ... and I have an SSD!


To fix it delete all your bookmarks, restart and then add back the ones you can't live without.

Using strace I realised that nautilus was stating lots of files for every view. Even files that were not in directory I was browsing during the trace. I think nautilus is trying to pre-cache these bookmarks.

I had one network drive as a bookmark ... this might have been the reason why nautilus was taking several seconds to load.

Preview settings:

Disable the previews in the preferences as follows:

enter image description here

share|improve this answer
nautilus is slow even when there are no boookmarks, it become slower when more files are added to HDD. – TheKojuEffect Feb 1 '13 at 2:16
A bookmark on a network did that for me. Preview do not make much of a difference. I also opened a bug about it upstream: – sup Feb 25 '13 at 15:03
@sup: Sorry for nitpicking as a programmer, but you opened a bug-report after you've found a bug. "Opening Bugs" leads to confusion should you talk to developers. – phresnel Oct 5 '15 at 15:54
Yeah, I guess you are right.. Even though I think it is rather clear what I meant from the context. – sup Oct 5 '15 at 19:27

I do not know if it is any help. But I removed the following plugins: nautilus-sendto, nautilus-sendto-empathy, nautilus-share, nautilus-open-terminal. Now Nautilus seems to be working quite fast.

share|improve this answer
Can't confirm this. I installed these extensions and still get the same issues. My testcase: $HOME/.thumbnails/ directory with ~50000 images (preview in nautilus deactivated). Observation: Nautilus slows down to a crawl, doesn't display files, has to be killed). Accessing /usr/bin with ~2800 items takes about 7 seconds. Both actions are near instant on PCmanFM and Dolphin. – Glutanimate Apr 3 '13 at 20:26
On second thought: There seem to be some speed-ups when accessing smaller directories (<50 items). Nautilus seems a bit more responsive. But these workaround obviously don't fix the underlying issue which is Nautilus itself. Thank you for posting this, though. Any help is appreciated! – Glutanimate Apr 3 '13 at 20:28

in your post you mention a murrine critical error surely this is the fault of some theme,which would explain why rooted nautilus works ok as root doesn't carry the user theme,try changing to default theme and test.

share|improve this answer
I recommend editing this to explain how to do that. – Eliah Kagan Apr 3 '13 at 3:55

This is most definitely an issue with Nautilus itself. Here is a bug report on launchpad:

Bug #869793 -Nautilus is very slow when opening folders with many files

share|improve this answer

This helps to lower the problems:
at preferences / behavior check open each folder on its own window
it lowers the usability, creating loads of windows; but at least you dont have to sit down and wait it finally respond like happens in Window$...

That problem may still happen and freeze all nautilus windows..., so I consider this as a temporary workaround that is not 100% and I still wait for a fix for nautilus.

This basically helps you avoid going back and forth on folders, by keeping them all opened.

EDIT: The slowdowns have stopped! but it is more difficult to use nautilus, but at least wont keep freezing all the time! (still freezes or whole crashes nautilus but takes more time)

share|improve this answer

Temporary fix at

Cause of the issue: Somehow "gvfsd-metadata" store got corrupted, as a result "gvfsd-metadata" get stuck on an infinite loop. Which in turn significantly affect the performance of nautilus. If you're not familiar with "gvfsd-metadata", it's is a process that collects file metadata when you use Nautilus file browser. We are assuming "gvfsd-metadata" is part of or related to "gvfs" package.

share|improve this answer

This worked for me:

sudo apt-get install --reinstall nautilus
share|improve this answer

I'm having problems like this too. After a couple of days of searching the web, there seem to be many very different things affecting nautilus's speed. I just upgraded to Fedora 20 (nautilus 3.10) and opening a new window always took way too long. On a whim, I deleted ~/.thumbnails/* and now nautilus windows open much faster. shrug

share|improve this answer

Nautilus is very slow on Ubuntu 14.04 too. I don't know why, maybe problems with plugins? I removed additional Nautilus plugins. It is still very slow and freezes sometimes. I think Canonical should do something, because Ubuntu rocks and should not troubled by a file manager.

I'm using the file manager Nemo as a workaround now for a couple of days. It is incredible fast and has got some really nice features compared to Nautilus. It will be my default file manager if there are no problems the next days.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.