Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I installed Ubuntu Server 12.04, I selected the ethernet adapter because I will use that most often; however, I would like to use wifi sometimes as well.

This is how far I've gotten with this problem.

lspci 
02:00.0 Network Controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection

iwconfig
wlan0  IEEE a/b/g/n  BSSID=off/any  Mode=Managed  Access Point=Not-Associated TX-Power=off  Retry Long Limit:7  RTS thr:off  Fragment thr:off  Power Management:off

I tried to do iwconfig wlan0 up but that doesn't work either. The error message said something along the lines of rfkill but I'm not connected to the Internet to download that particular program.

Any help here would be great

share|improve this question
    
did you solve the problem yet ? –  Suhaib Oct 22 '12 at 11:38
    
I haven't solved it yet. What I was trying to do was use the WiFi as a backup just in case my network went down. –  brievolz84 Nov 8 '12 at 1:13
add comment

1 Answer

What I would suggest is making sure that the drivers for your wireless card are correctly installed. And having a good look through the wireless troubleshooting.

Check for device recognition Open a Terminal (Applications → Accessories → Terminal) and type the command: sudo lshw -C network

You should see an output, along with the words "CLAIMED, UNCLAIMED, ENABLED or DISABLED"

Claimed - this indicates a driver is loaded but not functioning, see the section called “Using Windows Wireless Drivers”

Unclaimed - there is no driver loaded, see the section called “Using Windows Wireless Drivers”.

Enabled - there is a driver loaded, see the section called “Check for a connection to the router”.

Disabled - see the section called “Check that the device is on”.

This is from the ubuntu troubleshooting section on wireless. Try the following command.

sudo lshw -C network

This should give you a better idea of what your wireless card is doing.

share|improve this answer
    
I'll try this as soon as I get home –  brievolz84 Nov 8 '12 at 1:14
    
I tried that and looked over the the link you posted. The wireless troubleshooting puts me in a loop because the device is on but then the command lshw -C network tells me that my wifi is disabled so look to is it on...cycle repeats. I may try to install the wifi drivers via NDISWrapper –  brievolz84 Nov 8 '12 at 21:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.