Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm facing the problem that I can not set the activate hotkey to ALT+F3 in Synapse. It says "Failed to register hotkey....".

Nothing is listed in the settings for hotkeys which points to that combination...

I'am using Unity on Ubuntu 12.04.

Whats the problem?

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

The issue with your keyboard combination is that Alt is being used to trigger HUD and that prevents other applications from using any combination that involves Alt.

Possible things that you can do:

  • Use other combinations for activating Synapse, like Ctrl+F3. OR
  • Change the key that triggers HUD to something like Ctrl.
share|improve this answer
1  
Yopp. Thats the point. Hm, now i have to relearn... –  matcauthon Jun 7 '12 at 6:05
add comment

I had the same problem and my resolution to this:

  1. Activate Synapse's 'Start on login'
  2. Open up System Settings → Keyboard → Shortcuts
  3. Add a new shortcut to Custom Shortcuts that launches Synapse with a press of Alt+F2
share|improve this answer
add comment

The answer (of jokerdino) you have accepted is not an answer!! I keep on using synapse with alt+f3 shortcut till very this day, both on ubuntu 12.04 and 13.10, now even on linux mint 16 (KWin is blocking htis shortcut). The solution is simple but tricky! :) I took me a while to get there! :)

Step 1. Go to the System Settings -> Keyboard -> Shortcuts.

Step 2. Select Windows at the list on left side of the window. You will have a many unused events with trigger: disabled.

Step 3. Assign ALT+F3 to any of this disabled options and if any alert window will jump out it should tell you witch event is blocking this shorcut (on linux mint 16 it did but on not clean version of ubuntu 13.10, where i just created new user for this test there was no alert and i could simply assing this shorcut of ours :) )

Step 4. DISABLE it by selecting the row (the shorcut should change to "assing new" or something like that) and press backspace to make it disabled again!

Step 5. You're now free to assign this in your Synapse settings :) So to this just after you've done all of 5 steps.

Caution: in ubuntu 12.04 i remember that i had to install compiz manager, but i don't think that this is necessary anymore with this sollution. I would be glad if someone could check it for the sake of all of us! . :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.