Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Today ubuntu software center asked me to update things as usual, and I accepted.

But now when I open a new tab in firefox, it shows 9 'mini pages' taken from the history of visited pages.

How can I remove that? Does it have something to do with the 'ubuntu firefox modifications' addon?

share|improve this question

3 Answers 3

up vote 6 down vote accepted

There is another way if you want to get rid of it permanently. If you are happy with Matt2's solution there is no need to do so. I wanted remove it totally, because the mouse gestures provide by the extension All-in-one Gestures don't work on new tabs with the new startpage (by the way, I think its official name is new tab page).

Step 1

Enter this address to the location bar and confirm that you will be careful:


Screenshot 1

Step 2

Search for the preference with name:


Update: you can set browser.newtabpage.enabled (Step 2) to False (Step 3) instead of changing browser.newtab.url.

Screenshot 2

Step 3

Double click to modify and set the value to




if you prefer to see your own startpage (set its url in the standard preferences dialog).

Close the window, you're done!

share|improve this answer

On your new tab in Firefox, you see that button in the top right corner? Looks like a grid? Click it.

This is a new feature in Firefox and has nothing to do with any Ubuntu addons.

share|improve this answer
Thanks! ------- –  HappyDeveloper Jun 7 '12 at 3:10

Go to Edit → Preferences → General → Start Page and set it to:

share|improve this answer
This won't work in Firefox 13. This sets the startpage, but firefox loads the page about:newtab. –  lumbric Jun 11 '12 at 17:30
You are right, sorry.. it works only in new window but not on Ctrl-T.. –  Mat Jun 29 '12 at 9:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.