Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having a problem with my USB ports. It shows over-current conditions on ports 7 and 8. I have heard that this is caused by a damaged USB port, and since it is detecting it on two ports it seems that I have two that are broken. I do indeed have two that do not work, so that is not the issue.

What I would like to do is disable whatever program is running over-current condition checks. tty's are unusable at this point. Every few second a new over-current condition occurs.

Here is the output of dmesg: http://pastebin.com/CuFKRGue

Is there an easy way to disable these checks or damage the ports to a point where it will no longer check? Fixing them is not important or an option.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Add the following kernel option and see if it helps -- it tells the USB driver to ignore overcurrent (OC) alerts. This is only for USB 2.0 ports -- it will not work for USB 3.0, or USB 1.0 (unlikely if your computer was made after 2001 or so).

ehci_hcd.ignore_OC=1

Edit GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub to include this option and run sudo update-grub

Reboot and see; if it doesn't work, please pastebin full dmesg.

share|improve this answer
    
I know for sure that this will not work as the broken ports are USB 3.0. I should have mentioned that in my original question, but I figured since it's the current standard I could exclude it. I am going to go ahead and accept your answer since it DOES answer somebody who has this question with a USB 2.0 port. –  Dymatic Jun 7 '12 at 10:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.