Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I configure Skype to correctly use my Logitech USB Headset microphone?

I use Skype 2.1(Beta) with the following USB Headset:

input: Logitech Logitech USB Headset as /devices/pci0000:00/0000:00:1d.2/usb8/8-1/8-1:1.3/input/input6

generic-usb 0003:046D:0A0C.0002: input,hidraw1: USB HID v1.00 Device [Logitech Logitech USB Headset]

share|improve this question
1  
Is it a Logitech Clear Chat headset? –  theTuxRacer Nov 25 '10 at 5:27
    
I have a USB headset here, Its Turtle Beaches P11's But it doesnt show up. I payed good money for them, and they dont work. with anything. Do I need to use Windows to use these headphones or something? –  user142660 Mar 22 '13 at 22:40
    
if you are on x64 Ubuntu, this may help (as long as you have your sound working overall): $ sudo apt-get install libpulse0:i386 (courtesy vaelen.org/2013/06/03/skype-problems-on-ubuntu-13-04-64bit) –  mlvljr Sep 11 '13 at 17:10

3 Answers 3

up vote 11 down vote accepted

Check if you've configured the capture device (in Sound Preferences > Input) to your desired usb headset. You may also wish to 1) disallow Skype's managing your microphone levels; 2) unmute your microphone and raise the level to an amplified one (also in Sound Preferences > Input). Note also that if you're using 10.10, you'll need the latest updates installed for linux, alsa-lib, and pulseaudio.

share|improve this answer
    
thanks, works perfectly. –  taco24 Nov 24 '10 at 19:18

Install pavucontrol Install pavucontrol and make sure the correct device is being used for skype (both input and output).

share|improve this answer

Here's how I resolved my Logitech Headset through Skype problem. NOTHING is wrong with your headset if you hear music or video.

  1. Open Tools in Skype (go to "Tools" at the top menu, next to "Help")
  2. Click "Tools" and scroll down to the bottom for "Options" and click it
  3. Now scroll down to "Audio Settings" and click it
  4. the second category down is "Speakers". Inside the box you should read:

    Speakers (2-Logitech USB Headset).

    If it does not appear in the box, rather another speaker system, click the down (black, not green) arrow right next to the box. That speaker system is probably what you are seeing inside the box, which are your COMPUTER speakers, which Skype thinks you prefer.

    Assuming the "Logitech USB Headset" is also an option that you see, click Logitech. Now Logitech appears in the Speakers selection box.

  5. Go to the bottom and SAVE. This will tell Skype that you prefer Logitech Headset for your output speaker.

This is how I corrected my Logitech Headset and Skype problem. Works great now!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.