Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04 on my Dual screen desktop setup and its been working great. Even in 11.10 my computer wouldn't wake from Suspend. Its been bugging me and now I would like to do something about it.

Here is my lspci --> http://pastebin.ubuntu.com/1027728/

Still an amateur Ubuntu user, so let me know of any more information I can provide.

Thanks for your time.

share|improve this question
2  
if anyone have the same pb, and this was my case, you can find a solution here : http://ubuntuforums.org/showthread.php?t=2112830 I posted this thread to share the solution, after a long time of researches and It worked well for me. Hope this will help :-) –  Pouchette Dec 5 '13 at 18:01
    
+1 for link! it solved the issue on my end. I run 3 monitors with switchboard function, but I never had it wake up from sleep. Thanks. –  Faron Jan 6 at 20:56

1 Answer 1

I reckon it is this nvidia bug that is causing your woes:

https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-173/+bug/948053

The 173 nvidia branch is not available as a package for 12.04 and nvidia current doesn't work well for old cards. My solution was to get a new 600 series card, as I hope to avoid this kind of issue come october.

However there are a couple of other solutions.

Solution A use nouveau until the 173 driver is packages (it looks on that bug report that the new driver could be packaged pretty soon, subscribe to the bug report for email updates)

This will disable the nvidia_current driver and enable nouveau:

sudo jockey-text -d xorg:nvidia_current

Solution B

Download and execute this binary to build a 173 driver which works with the version of x.org precise ships with: ftp://download.nvidia.com/XFree86/Linux-x86/173.14.35/

This solution will break whenever an updated kernel is released unfortunately and will force you to rebuild the driver

share|improve this answer
    
This is interesting because when I go into system settings > details my "Graphics" are listed as "Unknown". I expect in the proper circumstances that my video card would be displayed there, because it is recognized by 'lspci' but not in the system details. –  Stanton.Sculpture Jun 7 '12 at 4:51
    
@Stanton.Sculpture, do you find Solution A / Solution B suggested above? What are the results? I have the same problem: can't resume whenever PC is suspended for long time (i.e., more than 1h approximately). –  Andrej Jun 14 '12 at 6:37
    
I've decided to wait until I can afford a new graphics card, I don't want to mess with the stability of my machine at this point, by screwing around with the 'sudo' command. –  Stanton.Sculpture Jun 14 '12 at 18:03
    
Update: I got a Gallium 0.4 on AMD REDWOOD graphics card a while ago and it works great now. I suspend it all the time now. –  Stanton.Sculpture Dec 7 '13 at 17:07
    
@Stanton.Sculpture so can this question be closed then? Or will you post this as an answer? –  RolandiXor Jan 6 at 20:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.