Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have GoldenDict installed in my Ubuntu 10.10. I am downloading A Spanish-English Dictionary in order to add it into the dictionary database of GoldenDict.

Once I add a path to search for the dictionary files and click on Rescan Now button in order to tell GoldenDict to index the new dictionary GoldenDict starts to index the dictionary and this process doesn't finish never. GoldenDict hangs on so that I need to kill it from the process. The dictionary I am trying to add is a file of 23.5Mb. I could add other dictionaries of 8-10Mb but not this one.

Any idea to solve my problem?

share|improve this question

2 Answers 2

Goldendict is looping while attempting to import the dictionary, it is a bug, you should file a bug report: https://help.ubuntu.com/community/ReportingBugs

share|improve this answer
up vote 1 down vote accepted

I have solved the problem of GoldenDict with looping while attempting to import the dictionary.

I was running GoldenDict in Guest Machine of VirtualBox and I only dedicated 1Gb of memory to the Guest Machine. I had noticed that when you give GoldenDict big dictionaries to index it consumes a lot of memory. So in my case it run out the memory (1Gb) and therefore were looping and hanging on.

I added another 1Gb of memory (so totaly I dedicated 2Gb memory) to the Guest Machine and tried to perform to import the dictionary again. This time GoldenDict could do its job, because it had sufficient memory to perform its tasks.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.