Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an ASROCK which uses Intel G31 graphics. Ubuntu says my graphics chipset is G33. Should I look for another driver or are they from the same family?

I am also having problems booting and that purple screen stuck so for this I asked this question. I have partially fixed the purple screen stuck by enabling (uncommenting) this line in grub:

GRUB_TERMINAL=console 

But Ubuntu still hangs at start up for about 15 minutes with a black screen and only the '_' prompt.

Here is a link for an overview of my ASROCK G31M-S

share|improve this question

1 Answer 1

I have an ASROCK G31M-S which uses Intel G31 graphics. Ubuntu says my graphics chipset is G33.

If the link you provided is for your motherboard then you have an Intel G31. I am not sure what you mean when you say Ubuntu says your graphics chipset is a G33. If Ubuntu does "say" this, then it is slightly confused.

If you look at the entries for the G31 & G33 chipsets in this table on Wikipedia, you can see that they are very similar. The primary difference between them is that the G31 uses the ICH7 southbridge and only supports 4 GB of RAM. The G33 uses an ICH9, can support 8 GB of RAM, and also can support DDR3 RAM.

In particular, both the G31 & G33 provide the same integrated graphics: Intel GMA 3100. In other words, there is no difference between the G31 & the G33 in terms of the type of graphics supported.


If the hang at the _ prompt occurs after the GRUB boot menu (or if you do not see a GRUB boot menu), then you might see if using the nomodeset kernel boot option helps.

Adding the nomodeset kernel option for a single boot

You can edit the boot instructions for the GRUB menu entry to add the nomodeset option to see if it corrects your graphics problem.

  1. Boot to the GRUB boot menu. An example of the menu is shown in the screenshot below.

    screenshot showing an example of the GRUB boot menu

    Note: If you do not see the GRUB boot menu when you boot, try pressing and holding the shift key immediately after the BIOS portion of the boot completes.
  2. Select (highlight) the GRUB boot menu entry for the Ubuntu kernel you wish to boot.
  3. Press e to edit the GRUB boot commands for the selected boot menu entry.
  4. Look near the bottom of the list of commands for lines similar to

    linux /boot/vmlinuz-3.2.0-24-generic root=UUID=bc6f8146-1523-46a6-8b\
    6a-64b819ccf2b7 ro quiet splash
    initrd /boot/initrd.img-3.2.0-24-generic

  5. Change the middle line in (4) by adding the kernel boot parameter nomodeset to the end of the line (i.e. after ro quiet splash).

    For this example you would change
    6a-64b819ccf2b7 ro quiet splash
    to
    6a-64b819ccf2b7 ro quiet splash nomodeset

  6. Without leaving this GRUB edit screen, press either Ctrl+X or F10 to boot using the modified kernel options.

Note: These changes are not persistent. Any change to the kernel boot options made this way will only affect the next boot and only if you start that boot by pressing either Ctrl+X or F10 while still in GRUB edit mode.

share|improve this answer
    
Thanks a lot for your time, I tried 'nomodeset' but it make the screen shaking so I guess it's not fit with my graphic chipset am also see GRUB menu every time I boot my PC and the _ prompt occur happen after the GRUB menu. –  Doctoa Jun 6 '12 at 22:55
    
I also added line after quiet splash that's I was should mention it earlier because am uncommented GRUB_TERMINAL=console it showed me after the grub menu "no video card detected" so I fixed that by adding "rootdelay=90". am also use 'GRUB coustomizer' app to do these stuff because it's GUI :) –  Doctoa Jun 6 '12 at 23:06
    
@Doctoa Was the error you were seeing no video card detected or no video mode activated? If it was the latter, this is not a serious error and does not need to be corrected. (And if it was the former, then how were you able to see the error message without a video card?) –  irrational John Jun 7 '12 at 2:27
    
wel it's 90 not 900. and when I change it to 5 it's now bring me the 'Busybox (initramfs)' method so I change it back to 90 and it's ok as past. –  Doctoa Jun 7 '12 at 6:56
    
I am not sure what you mean when you say Ubuntu says your graphics chipset is a G33. If Ubuntu does "say" this, then it is slightly confused Ubuntu show it on system information under Graphics chipset tap! –  Doctoa Jun 7 '12 at 7:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.