Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have problem with subtitle in Persian/Farsi using all good video players.

I have tested all reading options formats (all different area and language to read), but all did not work. I can type Farsi, but it can not show subtitle to Farsi.

share|improve this question

4 Answers 4

up vote 6 down vote accepted

If you have VLC may be I can help you.

Go to VLC:

  1. Click Tools and next Preferences
  2. Click Subtitle & OSD
  3. In section Subtitle Language and Default encoding
  4. Select Arabic (Windows-1256)
  5. In section font select the Tahoma font
share|improve this answer
Thank you Mahdi, I use this on SMPlayer. but for last part "5", I Push the "Enable Normal Subtitles" button, Really worked, THANKS. – Ali Jun 6 '12 at 20:59

Other way you may change subtites files encoding to UTF-8

I've experienced this before, and I found it's because of subtitles' font, use Subtitle Editor to edit your subtitle's font!

You can get Subtitle Editor two ways, Download from it's house or via PPA.

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install subtitleeditor
  • Right click on subtitle → open with → Subtitle Editor
  • Then Tools → Style Editor, and there you can change your subtitle's font.


share|improve this answer
Thank you for answer. – Ali Jun 6 '12 at 20:59

This is very simple using VLC :

  1. Go to Edit Menu
  2. Click on Preferences
  3. Change encoding to Arabic(Windows-1256)
  4. Change the Font to a Persian Font (I prefer B Nazanin)


share|improve this answer
i use vlc , so this is about VLC – HOS Oct 29 '14 at 6:24

control panel>Region>Administrative(tab)> change system local> change the current system location into Persian -> it may require restart your computer and when it did everything will look the same, but you can watch Persian subtitles just fine have fun ;)

if that didn't work and your using KMplayer: right click on main screen of kmplayer and go to: Option>preferences> in the left menu of the window select "subtitle processing" and in sub menus opened hit "font style" in the right side find the "charset" and change the box beside it to "Arabic"

that must do it

share|improve this answer
Change the system locale: The system locale determines the default character set (letters, symbols, and numbers) and font used to enter and display information in programs that don't use Unicode. This allows non-Unicode programs to run on your computer using the specified language. – shirin Sep 7 at 4:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.