Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After update (yesterday) from Ubuntu 12.04, GRUB has two of the same kernels in the boot menu for Ubuntu 12.04 (I have triple boot). I have already reinstalled GRUB, but with the same result. It seems to me that something is going wrong in update-grub:

Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.2.0-24-generic-pae
Found initrd image: /boot/initrd.img-3.2.0-24-generic-pae
Found linux image: /boot/vmlinuz-3.2.0-24-generic-pae
Found initrd image: /boot/initrd.img-3.2.0-24-generic-pae
Found Windows Vista (loader) on /dev/sda2
Found Ubuntu 11.04 (11.04) on /dev/sda7
done

There is no problem for boot but this is not nice. Solution?

share|improve this question
    
Please provide the output of sudo fdisk -l –  shantanu Jun 6 '12 at 18:54
1  
dpkg --list | grep linux-image-generic please –  izx Jun 6 '12 at 18:54
1  
Use step 5: tuxtweaks.com/2010/10/… don't forget to run sudo update-grub –  shantanu Jun 6 '12 at 18:58
    
dpkg --list | grep linux-image-generic give as result: ii linux-image-generic-pae 3.2.0.24.26 Generic Linux kernel image –  Julien Chau Jun 6 '12 at 19:03
    
/dev/sda1 63 16787924 8393931 27 Hidden NTFS WinRE /dev/sda2 * 16787928 141916159 62564116 7 HPFS/NTFS/exFAT /dev/sda3 141916160 299204607 78644224 7 HPFS/NTFS/exFAT /dev/sda4 299206654 781402111 241097729 5 uitgebreid /dev/sda5 388919296 697753599 154417152 7 HPFS/NTFS/exFAT /dev/sda6 760293376 781402111 10554368 7 HPFS/NTFS/exFAT /dev/sda7 299206656 383795199 42294272 83 Linux /dev/sda8 383797248 388917247 2560000 82 Linux swap /dev/sda9 97755648 760291327 31267840 83 Linux –  Julien Chau Jun 6 '12 at 19:07
show 6 more comments

2 Answers

up vote 0 down vote accepted

Finally I found the reason why. Sometime ago I made some changes to the file /etc/grubd.d/10_linux . For security reasons I made a copy of this file (.bak). This file was still executable. It has never caused problems till the last update of the system. The only thing I had to do was a chmod so this file (.bak) so he was no longer executable. By doing sudo update-grub all the files that are present in the /etc/grub.d and are executable are taken in the grub.cfg file, what caused the problem.

share|improve this answer
add comment

Sorry, I think you're suppose to use: update-grub2

Try to see if this is the fix. It's working for me just fine on old Maverick.

share|improve this answer
    
update-grub2 is actually a symbolic link to the update-grub script in /usr/sbin/ –  Samik Jun 6 '12 at 19:17
    
that is correct update-grub is OK. But update-grub does not fix the problem.(see my question). It is not a old kernel - it is the latest kernel. –  Julien Chau Jun 6 '12 at 19:23
    
@JulienChau yes, my actual intention was to inform that you have already tried that. –  Samik Jun 6 '12 at 19:26
    
I did understand this Samik - my answer was in the first place to Frese –  Julien Chau Jun 6 '12 at 19:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.