Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've install the nvidia drivers from the "Additional drivers" menu in the settings,

and when I try to resume from suspend, I get black screen and I have to reboot for solve it.

How can I fix it? It's very important to me, Thanks!!

share|improve this question

This may not be the source of your issue but I would wager that it is.

For older cards sometimes the nvidia_current driver doesn't work very well. On Oneiric there was packages for the 173 and 96 branch of nvidia driver, however when precise was released the nvidia driver for the 127 and 96 branches wasn't released, nvidia have since published an updated 173 driver, but it has not been packaged.

As you can see it has been assigned now and looks like it will be probably packaged shortly. In the mean time you can either use the nouveau drivers or build the driver by executing this .run file the problem with doing that though is that kernel updates will mean you have to rebuild the driver.

Or do what I did and get fed up and buy a new nvidia card, my reasoning is with using that old card I'll probably get hit with this crap again in October...

I will never understand why gets revved every Ubuntu release with all the inevitable driver issues...

share|improve this answer
So there's no solution to the sleep and resume issue?.. – nimrod Jun 7 '12 at 11:17
No, there is a solution... install the nvidia 173 driver. It's just not as simple as it being packaged in the repo take this .run file and execute it to build the driver use this guide for more info. – MickStep Jun 7 '12 at 14:20
OK, I will try. thank you! Do you know what is the reason for the suspend-resume problem? – nimrod Jun 7 '12 at 16:28

Try to install nvidia drivers from X-Swat repo:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current
share|improve this answer
I've already install it .. – nimrod Jun 6 '12 at 18:20
I'm having the same issue with the x-swat driver – jasonwert Jun 20 '12 at 15:49

First of all, uninstall the current driver via Additional drivers. Then select and activate another driver. If you were using Recommended driver use instead Post-release update driver. You wont have problems because Nvidia is more supported than AMD.

share|improve this answer
I tried, it doesn't help .. :\ – nimrod Jun 6 '12 at 18:20

the x-swat install worked in conjunction with the script mentioned in Suspend not properly working with ASUS. - the full script solution is in answer 1. Now wakeup from suspend works perfectly. Xorg is very temperamental and was the source of much frustration for me until I was able to cede control to the Debian developers a few years ago.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.