Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 11.04. I have an NVidia GeForce GTX 295 card installed with driver version 295.53 installed. I had struggled with this for a while a few weeks ago, and gave up. However, last week, I came into work, and noticed both monitors were working. I thought one of my tech buddies helped me out (we are a small company, and I just spoke with him today. He thought it was still not working) so I went on my merry way happy that I had dual monitor support. Unfortunately, I crashed (tried to compile a program while running a large virtual box) the computer yesterday, and when it came back up, I was back to a single monitor again. I had not changed any settings or files related to any software installed.

TL;DR: Dual monitor support started working out of the blue, and upon reboot, disappears.

Any thoughts on where to go?

A few notes:

I understand about duplicate questions. I have tried a number of solutions from a wide range of websites, including this one, but none of them seem to help, or be relevant to my situation.

My xorg.conf file is as follows (which I assume was the correct mix of settings):

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 295.53  (buildmeister@swio-display-x86-rhel47-07.nvidia.com)  Sat May 12 00:34:20 PDT 2012

#Section "Monitor"
#Identifier     "Monitor2"
#VendorName     "Unknown"
#ModelName      "Unknown"
#HorizSync       28.0 - 33.0
#VertRefresh     43.0 - 72.0
#Option         "DPMS"
#EndSection
#Section "Device"
#Identifier     "Device0"
#Driver         "nvidia"
#VendorName     "NVIDIA Corporation"
#BoardName      "GeForce GTX 295"
#BusID          "PCI:4:0:0"
#EndSection
#Section "Screen"
    #Identifier     "Screen1"
    #Device         "Device1"
    #Monitor        "Monitor1"
    #DefaultDepth    24
    #Option         "TwinView" "True"
    #Option         "MetaModes" "nvidia-auto-select, nvidia-auto-select"
    #SubSection     "Display"
        #Depth       24
    #EndSubSection
#EndSection
#Section "Screen"
    #Identifier     "Screen2"
    #Device         "Device2"
    #Monitor        "Monitor2"
    #DefaultDepth    24
    #Option         "TwinView" "True"
    #Option         "MetaModes" "nvidia-auto-select, nvidia-auto-select"
    #SubSection     "Display"
        #Depth       24
    #EndSubSection
#EndSection

Section "ServerLayout"

#Screen      1  "Screen1" RightOf "Screen0"
#Screen      2  "Screen2" RightOf "Screen1"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 295"
    BusID          "PCI:5:0:0"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 295"
    BusID          "PCI:4:0:0"
EndSection

Section "Screen"

#Option         "TwinView" "True"
#Option         "MetaModes" "nvidia-auto-select, nvidia-auto-select"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "True"
    Option         "MetaModes" "nvidia-auto-select, nvidia-auto-select"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"

#Option         "TwinView" "True"
#Option         "MetaModes" "nvidia-auto-select, nvidia-auto-select"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "True"
    Option         "MetaModes" "nvidia-auto-select, nvidia-auto-select"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
share|improve this question
    
To further clarify: NVidia settings panel (even when run using sudo) can't find the second monitor. –  Drise Jun 6 '12 at 15:15
    
To further clarify: I am trying to use TwinView. –  Drise Jun 6 '12 at 15:16
    
I figured out the solution: The cable was loose. –  Drise Oct 17 '12 at 15:50
add comment

2 Answers

I would recommend using the nvidia's x configuration tool to accomplish this, as for as long as ive been hand editing xorg.conf's (since 2002) it seems to change drastically based on the drivers, card and distro xorg server and xrandr support.

For what it's worth, here's my xorg setup from ubuntu 10.04 LTS which has compositioning and acceleration enabled (I'm using compiz-fusion on it and twin view)

The key question to me based on your file is if you are trying to get twin view or two separate heads. in other words: one big spanning screen across both monitors? thats what my setup is doing.


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@yellow)  Fri Apr  9 11:51:21 UTC 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load       "type1"
    Load       "freetype"
EndSection

Section "ServerFlags"
    Option  "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL 1908FP"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro NVS 290"
    BusID          "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option     "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-1: nvidia-auto-select +1280+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
share|improve this answer
    
Damn, I forgot to include that the NVidia settings panel (even when run using sudo) can't find the second monitor, and from my experience with working with this, is practically useless. –  Drise Jun 6 '12 at 15:14
add comment

I see you're using 295.53. Just to be safe could you try:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current
share|improve this answer
    
I'll give it a shot, I just hope this doesn't break my working monitor. –  Drise Jun 6 '12 at 15:18
    
Ok, rebooted. Still on 295.53.. –  Drise Jun 6 '12 at 15:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.