Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently been updating from Lynx and am currently at 11.10 However when I restarted the computer I couldn't get any wired connection (which is what I use). When I click at the top it just says that the connection is disconnected, which it isn't ... I'm a bit of a newbie at Ubuntu so I may have missed something obvious but if any of you guys could help that would be great! :D

Edit: My ifconfig result is

Link evaluate: local loopback
Inet addr:127.0.0.1 Scope:Host
Up Loopback Running MTU :16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes (0.0 B)

I've checked the cable and that is definately working. I also get Usage: dmesg [-c] [-n level] [-r] [-s bufsize]

share|improve this question
1  
Could you include the output of ifconfig ? –  Mitch Jun 6 '12 at 12:54
    
The most obvious thing to do is check the cable. If it's right it's likely a driver issue. Can you add more info about your hardware?. Can you add the output o dmesg | grep eth? –  Javier Rivera Jun 6 '12 at 13:58
    
@Kieran Your edits are coming through as a logged out user, that's why you can't edit your question right away. –  Jorge Castro Jun 6 '12 at 14:14
    
The | is not an l, but a pipe. This is likely why the command is failing. –  Javier Rivera Jun 6 '12 at 15:25
add comment

2 Answers

he way I fixed mine (same prob)was to go to 'Edit Connection's change the "Connection name"

to Auto(eth0)-MTU:is Automaic(DHCP)-Tick both "Require IP4 addressing for this connection to complete,and "Available to all users"

IP v6 Settings: Should be "Ignore", and also tick "Available to all users"

share|improve this answer
add comment

Easy route:

Use sudo dhclient and hope your DHCP server assigns an IP address, default gateway, and name servers (DNS).

Long route:

ifconfig on it's own only display configured network cards. It seems for now your network card is unconfigured and you are viewing your loopback adapter which is a default adaptor that should always be there.

Try ifconfig -a. This will display all cards available and the ethernet interface id for those cards. Look for something like eth0 or eth1.

To quickly configure a card, do something like this: sudo ifconfig eth0 192.168.0.2.

Of course eth0 is dependant on the result of your ifconfig -a and the IP address is dependant on your environment.

This will bring your machine online. Now you can hopefully ping your default gateway.

To assign your default gateway do this: sudo route add default gw 192.168.0.1

Again the IP 192.168.0.1 is dependant on your environment. If you have a Windows machine you can do ipconfig -all to get most of the required information.

Now you can hopefully ping the Internet, but you won't be able to resolve names. So you can ping 196.25.1.1 but not ping www.google.com. For that you have to assign a DNS server. To do this:

Edit /etc/resolv.conf

I use mc -e (Midnight Commander) but you might prefer to use vi which is built into most Unix systems.

Add the following to resolv.conf:

nameserver 8.8.8.8

and save. Now you should be able to ping the Internet and get online using a browser. You are temporarily using Google's public name server at 8.8.8.8.

At this point we normally install Webmin :-) http://www.webmin.com/

Webmin makes is 10x easier to configure and check network cards. In Webmin, use the Networking / Network Configuration and then:

Network Interfaces (IP address) Routing and Gateways (Default gateway) Hostname and DNS Client (DNS servers)

menus to configure your card.

Checking /etc/network/interfaces

You might also want to check /etc/network/interfaces because that is where the resultant configuration information is stored. On a DHCP enabled machine you have something like this:

user@computer:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

On a fixed IP machine you will have values like this (depends on environment):

user@computer2:~# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The auto command
auto lo eth1

# The loopback network interface
iface lo inet loopback

# The rest
iface eth1 inet static
    address 192.168.0.2
    netmask 255.255.255.0
    broadcast 192.168.0.255
    network 192.168.0.0
    gateway 192.168.0.1

Please note the above file contains just the IP address and default gateway.

The sum of our solution is to get the IP address, default gateway, and DNS servers (in /etc/resolv.conf) right. Good luck, this can sometimes be a bit of a nightmare if it doesn't work right out the box / upgrade.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.