Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Unity, whenever authentication is required and when the PolicyKit authentication agent window is presented, it stays there even after I would enter a faulty password. But under Gnome Shell, whenever I make a mistake, the window is closed immediately. I find this behaviour irritating.

For instance I use Synaptic rather frequently, and I prefer to start it using Synapse. I press Ctrl+Space to invoke Synapse, then I enter "syn" (s-shows SMplayer, sy- shows System Monitor) and than I press Enter so that Synaptic is invoked. Then I'm presented with the PolicyKit authentication agent window. As my password is rather complicated - using special characters and big letters, it's easy to make a mistake. If I do make a mistake while typing my password, I'm forced to redo all the previous steps. It's annoying as hell, knowing that this is not the way the PolicyKit authentication agent window behaves in Unity.

share|improve this question
    
This is strange. On my system (also 12.04) I get 3 tries. What does your /usr/share/polkit-1/actions/com.ubuntu.pkexec.synaptic.policy file look like? Specifically the defaults - allow_active field. If it is auth_admin_one_shot that would explain the behavior. If so, just change it to auth_admin. –  Chris Jun 6 '12 at 4:22
    
Everything looks as you say it is supposed to be in the /usr/share/polkit-1/actions/com.ubuntu.pkexec.synaptic.policy file. This is a clean 12.04 installation, and I've never played with any PolicyKit settings –  Petar Jun 6 '12 at 14:20
    
@Chris I just tried with Unity again, and it seams that this behaviour is Gnome Shell specific so i reedited my question. –  Petar Jun 6 '12 at 15:05
    
That is the limit of my experience with PK. As a work around, you may try creating a new .desktop file for synaptic that uses gksudo instead of pkexec. I don't know if gksudo will perform better, but it may. The fact that the behavior is different with Gnome Shell would indicate that this may be a bug. Perhaps someone else will have a better solution. Good Luck. –  Chris Jun 7 '12 at 22:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.