Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a computer (10.04) that was previously running Thunderbird 12.0.1 just fine (installed via apt-get via official PPA). I don't know what happened at the time the problem started since this is a multi-user computer and I was not here. However, every time we try to launch TB, we immediately get a dialog that says:

We're Sorry
Thunderbird had a problem and crashed.

Things I've tried:

  • Running thunderbird from a terminal produces no output.
  • I tried apt-get remove thunderbird --purge and then reinstalled
  • Deleting the user's .thunderbird folder and launching still results in a crash
  • Attempting to run thunderbird -safe-mode still results in a crash
  • This problem occurs for all users of Thunderbird on this computer.

Is there any way to get more details on why the program is crashing? For example, the specific error that TB is encountering? I tried thunderbird -g but I'm not sure what to do with the debugger.


apt-cache policy thunderbird

  Installed: 12.0.1+build1-0ubuntu0.10.04.1
  Candidate: 12.0.1+build1-0ubuntu0.10.04.1
  Version table:
 *** 12.0.1+build1-0ubuntu0.10.04.1 0
        500 lucid-updates/main Packages
        500 lucid-security/main Packages
        100 /var/lib/dpkg/status
     11.0.1+build1-0ubuntu0.10.04.1~mts1 0
        500 lucid/main Packages
     3.0.4+nobinonly-0ubuntu4 0
        500 lucid/main Packages
share|improve this question
Are you still using the PPA version of Thunderbird? What's the output of running apt-cache policy thunderbird in the Terminal? – Eliah Kagan Jun 5 '12 at 21:26
The output of apt-cache policy thunderbird has been added above. – Nick Jun 6 '12 at 0:12
This confirms that you are running Ubuntu's official version of Thunderbird (and not a PPA version). There might be systemwide configuration files left over from when the PPA was installed, that would cause this problem (though I don't think this is extremely likely). I'll edit my answer to tell you how to fix this. – Eliah Kagan Jun 6 '12 at 0:37
up vote 3 down vote accepted

Reporting and Getting Information About this Crash Bug

Since this is a bug (application crashes are definitely not intended behavior), you can do the following.

  1. Enable Apport crash reporting, so that when the crash happens next, information will be automatically gathered, displayed, and (if you wish, which I highly recommend) submitted for attachment to your bug report.

  2. When you submit the information to Launchpad for attachment to your bug report, a new browser window/tab will open. Wait for the information to be processed, and you'll be able to describe what happened (as best you can).

  3. Launchpad may suggest existing bugs that this is a duplicate of. If any come up, you can read the information written there and see if you think you can be pretty sure yours is the same. If not, submit your bug report--it can be marked as a duplicate of another bug later, if it turns out to be one.

  4. Before submitting the bug report, please read this thoroughly and carefully, as that explains the important considerations for reporting bugs in Ubuntu. That also explains the whole process in more detail than this answer. (You may want to do read this even before doing the other steps.)

  5. When you're happy with your bug report, submit it. It may be marked as a duplicate of another bug, and if so, you might find information in that bug. Even if not, triagers and developers, in the process of investigating your bug, may be able to give you information that would help. And even if they cannot, submitting the bug report is the first step to getting the bug fixed, which should help you and anyone else suffering from it.

A Possible Workaround for Thunderbird Crashes In General

Many Firefox and Thunderbird crashes happen because of bugs handling your profile or other user-specific data. You should see if the crash occurs when you run Thunderbird in another user account. (If you only have one account, you can create another one to test this.)

If the problem does not occur when you run Thunderbird in another user account, then you can move your Thunderbird profile "out of the way" by renaming the directory that contains it. Thunderbird will not have access to your locally stored emails, and you'll have to reconfigure it for all your email accounts, but this may solve the problem for you, and this also useful information for your bug report.

I recommend submitting your bug report before doing this, so that information from the crash gets submitted even if this technique solves the problem and you don't want to reverse it. Then you can edit your bug report to include information about what happened. Alternatively, produce the crash, submit the crash data to Launchpad, try this, and include information about it in your original bug report.

To move your Thunderbird profile out of the way:

  1. Make sure Thunderbird is not running.

  2. In your home directory, find the folder called .thunderbird. (You will have to do View > Show Hidden Files--or Ctrl+H--in the Nautilus file browser to see it, as files and folders that start with a . are hidden by default.)

  3. Rename this file to thunderbird.old.

  4. Start up Thunderbird.

Alternatively, you may prefer to do this from the Terminal:

  1. Make sure Thunderbird is not running.

  2. Open the Terminal (Ctrl+Alt+T).

  3. Run this command:

    mv ~/thunderbird ~/thunderbird.old
  4. Start up Thunderbird.

I think some older versions of Thunderbird might store your profile in ~/.mozilla/thunderbird rather than ~/.thunderbird, so if ~/.thunderbird doesn't exist, you might want to look in ~/.mozilla.

Ensuring All Systemwide Configuration Files From the PPA Version Are Removed

The output of apt-cache policy thunderbird confirms that the PPA version is no longer installed. However, it's possible that there are some systemwide configuration files left over from it. It may have left systemwide configuration data that the newer version (from Ubuntu's official software sources) is choking on. To account for the possibility that it left configuration files other than those automatically created by the current version, you should purge not just the current systemwide configuration data, but the old one too. And this is an opportunity to reinstall Thunderbird as well, in case the installation is somehow corrupted.

So, the following directions do the following:

  1. Remove Thunderbird and all its systemwide configuration files.

  2. Install the old PPA version of Thunderbird. (This is temporary, and only to facilitate remove it more completely than before.)

  3. Remove the old PPA version of Thunderbird and all its systemwide configuration data files.

  4. Reinstall Thunderbird (the current version, from the official software sources).

Here's how to achieve this:

  1. Make sure Thunderbird is not running.

  2. Run these commands in a Terminal window:

    sudo apt-get --purge --reinstall install thunderbird=11.0.1+build1-0ubuntu0.10.04.1~mts1
    sudo apt-get update
    sudo apt-get --purge --reinstall install thunderbird
  3. Run Thunderbird, and see if the problem is fixed.

This will probably not help...but it might fix the problem, and it's definitely worth trying. If/when you report this as a bug, whether or not this worked will be relevant. (Though if it does work, you might decide not to report the bug.)

Please note that your current systemwide Thunderbird configuration files (if any) will also be purged, but that won't make you lose stored emails or account settings because that is user-specific rather than systemwide.

share|improve this answer
Regarding the Thunderbird profile folder, it's actually ~/.thunderbird not ~/.mozilla/thunderbird. I had tried that previously but still got the crash. It also crashes for all users of the computer. I'll try your other suggestions and report back. Thanks! – Nick Jun 5 '12 at 23:39
@Nick Thanks. It's important that I correct this error in my answer. My recollection is that it at least used to be ~/.mozilla/thunderbird. Do you know if it changed in a recent version? – Eliah Kagan Jun 5 '12 at 23:42
I'm not sure if this changed or not... Firefox is still under ~/.mozilla/. – Nick Jun 6 '12 at 0:39
@Nick I'll look into this, and try to fix it soon. Meanwhile, I added a section on making sure all systemwide configuration files are purged from older Thunderbird installations. – Eliah Kagan Jun 6 '12 at 0:48
I'm marking this as solved- removing all files (locate thunderbird), then rebooting, then reinstalling seems to fix the problem. It seems that apt-get remove --purge thunderbird doesn't actually remove everything, since there were still entries in /usr/bin/thunderbird afterwards. Thanks for your help! – Nick Jun 6 '12 at 1:32

I experienced the same behaviour on 12.04.

I disabled all Add-ons in safe mode:

thunderbird -safe-mode

what had no effect.

After that I remove and installed thunderbird

sudo apt-get remove thunderbird
sudo apt-get install thunderbird

which allowed me to restart thunderbird.

Afterwards I activated the Add-ons one by one.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.